dev-python/pypeg2: Modernize, EAPI 7, py3.8
authorMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 12:05:48 +0000 (13:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 13:59:06 +0000 (14:59 +0100)
Closes: https://bugs.gentoo.org/709970
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild b/dev-python/pypeg2/pypeg2-2.15.2-r1.ebuild
new file mode 100644 (file)
index 0000000..f4105ac
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN=pyPEG2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An intrinsic PEG Parser-Interpreter for Python"
+HOMEPAGE="https://fdik.org/pyPEG/
+       https://bitbucket.org/fdik/pypeg/
+       https://pypi.org/project/pyPEG2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.15.1-test.patch )
+
+distutils_enable_tests unittest