dev-python/paho-mqtt: Run pytest directly
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 11:13:57 +0000 (12:13 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 11:40:55 +0000 (12:40 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/paho-mqtt/paho-mqtt-1.4.0.ebuild
dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild

index d37ae460afc2d575efe31252fad920d087f76ed5..59c911774320698db22fc974cc43e03f93de8369 100644 (file)
@@ -9,29 +9,24 @@ inherit distutils-r1
 DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
 HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
 SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
 
 LICENSE="EPL-1.0"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
 
 RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
        test? (
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
        ) "
 
-S="${WORKDIR}/paho.mqtt.python-${PV}"
-
 RESTRICT="test" #659106
 
+distutils_enable_tests pytest
+
 src_prepare() {
        eapply "${FILESDIR}/${PN}-1.3.1-strip-test-dependency.patch"
        default
 }
-
-python_test() {
-       esetup.py test
-}
index c85da6521637ab33137d4c74f7e9ed1b9a4f9027..b72e1c3b5b9741086e4f03485aefe4273e96cd2c 100644 (file)
@@ -9,29 +9,23 @@ inherit distutils-r1
 DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
 HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
 SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
 
 LICENSE="EPL-1.0"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
        test? (
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
                dev-python/six[${PYTHON_USEDEP}]
        ) "
 
-S="${WORKDIR}/paho.mqtt.python-${PV}"
+distutils_enable_tests pytest
 
 src_prepare() {
        eapply "${FILESDIR}/${P}-strip-test-dependency.patch"
        default
 }
-
-python_test() {
-       esetup.py test
-}