add in 4.2.0_rc1, remove 4.2.0_pre1
authorCaleb Tennis <caleb@gentoo.org>
Wed, 6 Sep 2006 12:15:50 +0000 (12:15 +0000)
committerCaleb Tennis <caleb@gentoo.org>
Wed, 6 Sep 2006 12:15:50 +0000 (12:15 +0000)
Package-Manager: portage-2.1.1_rc1-r1

x11-libs/qt/ChangeLog
x11-libs/qt/files/digest-qt-4.2.0_rc1 [new file with mode: 0644]
x11-libs/qt/qt-4.2.0_rc1.ebuild [new file with mode: 0644]

index 93e75e078c9d4f6dd5bd9dbd1daba5305c6327d8..ae48b0ec86ba1094baaa13ee41f13d153961ee6b 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/qt
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.343 2006/09/02 18:02:05 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.344 2006/09/06 12:15:50 caleb Exp $
+
+*qt-4.2.0_rc1 (06 Sep 2006)
+
+  06 Sep 2006; Caleb Tennis <caleb@gentoo.org> -qt-4.2.0_pre1.ebuild,
+  +qt-4.2.0_rc1.ebuild:
+  add in 4.2.0_rc1, remove 4.2.0_pre1
 
   02 Sep 2006; Bryan Ã˜stergaard <kloeri@gentoo.org> qt-4.1.4.ebuild:
   Stable on ia64.
diff --git a/x11-libs/qt/files/digest-qt-4.2.0_rc1 b/x11-libs/qt/files/digest-qt-4.2.0_rc1
new file mode 100644 (file)
index 0000000..3676b4f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 abea80e4ec7fe232db63c125c74e917d qt-x11-opensource-src-4.2.0-rc1.tar.gz 36935130
+RMD160 03e8a54e170bf3be3c050833b56a6212bae50c6b qt-x11-opensource-src-4.2.0-rc1.tar.gz 36935130
+SHA256 061c6071064bc635f783523c6d25138a21683cc14b7564645ab80d51c476248c qt-x11-opensource-src-4.2.0-rc1.tar.gz 36935130
diff --git a/x11-libs/qt/qt-4.2.0_rc1.ebuild b/x11-libs/qt/qt-4.2.0_rc1.ebuild
new file mode 100644 (file)
index 0000000..ce2bae1
--- /dev/null
@@ -0,0 +1,210 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.0_rc1.ebuild,v 1.1 2006/09/06 12:15:50 caleb Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SRCTYPE="opensource-src"
+DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework."
+HOMEPAGE="http://www.trolltech.com/"
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${SRCTYPE}-${PV/_rc/-rc}.tar.gz"
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV/_rc/-rc}
+
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="4"
+#KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="-*"
+IUSE="accessibility cups debug dbus doc examples firebird gif glib jpeg mng mysql nas nis odbc opengl pch png postgres sqlite xinerama zlib"
+
+# need glib and dbus
+
+DEPEND="|| ( ( x11-libs/libXrandr
+                       x11-libs/libXcursor
+                       x11-libs/libXi
+                       x11-libs/libXfont
+                       x11-libs/libSM
+                       x11-proto/xextproto
+                       x11-proto/inputproto
+                       xinerama? ( x11-proto/xineramaproto x11-libs/libXinerama )
+               )
+               <virtual/x11-7
+       )
+       virtual/xft
+       >=media-libs/freetype-2
+       dbus? ( >=sys-apps/dbus-0.62 )
+       png? ( media-libs/libpng )
+       jpeg? ( media-libs/jpeg )
+       mng? ( media-libs/libmng )
+       nas? ( >=media-libs/nas-1.5 )
+       odbc? ( dev-db/unixODBC )
+       mysql? ( dev-db/mysql )
+       firebird? ( dev-db/firebird )
+       opengl? ( virtual/opengl virtual/glu )
+       postgres? ( dev-db/libpq )
+       cups? ( net-print/cups )
+       zlib? ( sys-libs/zlib )
+       glib? ( dev-libs/glib )"
+
+pkg_setup() {
+       QTBASEDIR=/usr/$(get_libdir)/qt4
+       QTPREFIXDIR=/usr
+       QTBINDIR=/usr/bin
+       QTLIBDIR=/usr/$(get_libdir)/qt4
+       QTPCDIR=/usr/$(get_libdir)/pkgconfig
+       QTDATADIR=/usr/share/qt4
+       QTDOCDIR=/usr/share/doc/${PF}
+       QTHEADERDIR=/usr/include/qt4
+       QTPLUGINDIR=${QTLIBDIR}/plugins
+       QTSYSCONFDIR=/etc/qt4
+       QTTRANSDIR=${QTDATADIR}/translations
+       QTEXAMPLESDIR=${QTDATADIR}/examples
+       QTDEMOSDIR=${QTDATADIR}/demos
+
+       PLATFORM=$(qt_mkspecs_dir)
+}
+
+qt_use() {
+       useq ${1} && echo "-${1}" || echo "-no-${1}"
+       return 0
+}
+
+qt_mkspecs_dir() {
+       # Allows us to define which mkspecs dir we want to use.  Currently we only use
+       # linux-g++ or linux-g++-64, but others could be used for various platforms.
+
+       if [[ $(get_libdir) == "lib" ]]; then
+               echo "linux-g++"
+       else
+               echo "linux-g++-64"
+       fi
+}
+
+src_unpack() {
+
+       unpack ${A}
+#      epatch ${FILESDIR}/qt4-parisc-linux.diff
+       cd ${S}
+
+       sed -i -e 's:read acceptance:acceptance=yes:' configure
+
+       cd mkspecs/$(qt_mkspecs_dir)
+       # set c/xxflags and ldflags
+
+       # Don't let the user go too overboard with flags.  If you really want to, uncomment
+       # out the line below and give 'er a whirl.
+       strip-flags
+       replace-flags -O3 -O2
+
+       sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
+               -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
+               -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
+               qmake.conf
+
+       # Do not link with -rpath. See bug #75181.
+       sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" \
+               qmake.conf
+
+       # Replace X11R6/ directories, so /usr/X11R6/lib -> /usr/lib
+       sed -i -e "s:X11R6/::" qmake.conf
+
+       cd ${S}
+
+       if [[ "$(gcc-major-version)" == "4" ]]; then
+               einfo "Visibility support: auto"
+       else
+               einfo "Visibility support: disabled"
+               sed -i -e "s:CFG_REDUCE_EXPORTS=auto:CFG_REDUCE_EXPORTS=no:" configure
+       fi
+}
+
+src_compile() {
+       export PATH="${S}/bin:${PATH}"
+       export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+       [ $(get_libdir) != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
+
+       myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
+       myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
+
+       use nas         && myconf="${myconf} -system-nas-sound"
+       use gif         && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
+       use png         && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
+       use jpeg        && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
+       use debug       && myconf="${myconf} -debug-and-release" || myconf="${myconf} -release"
+       use zlib        && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
+
+       use mysql       && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
+       use postgres    && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
+       use firebird    && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
+       use sqlite      && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
+       use odbc        && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
+
+       use dbus        && myconf="${myconf} -qdbus" || myconf="${myconf} -no-qdbus"
+       use glib        && myconf="${myconf} -glib" || myconf="${myconf} -no-glib"
+
+       use pch         && myconf="${myconf} -pch"
+
+       myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
+
+       ./configure -stl -verbose -largefile \
+               -platform ${PLATFORM} -xplatform ${PLATFORM} \
+               -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
+               -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
+               -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} \
+               -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR} ${myconf} || die
+
+       emake sub-tools-all-ordered || die
+       if use examples; then
+               emake sub-examples-all-ordered || die
+       fi
+}
+
+src_install() {
+       export PATH="${S}/bin:${PATH}"
+       export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
+
+       make INSTALL_ROOT=${D} sub-tools-install_subtargets-ordered || die
+
+       if use examples; then
+               make INSTALL_ROOT=${D} sub-examples-install_subtargets || die
+               make INSTALL_ROOT=${D} sub-demos-install_subtargets || die
+       fi
+
+       make INSTALL_ROOT=${D} install_qmake || die
+       make INSTALL_ROOT=${D} install_mkspecs || die
+
+       if use doc; then
+               make INSTALL_ROOT=${D} install_htmldocs || die
+       fi
+
+       # Install the translations.  This may get use flagged later somehow
+       make INSTALL_ROOT=${D} install_translations || die
+
+       # The private header files of QTestLib aren't installed, but are needed by the test library.
+       # This is supposedly fixed in Qt 4.1.1, so this can probably be removed when it is released
+       dodir ${QTHEADERDIR}/QtTest/private
+       cp -pPR ${S}/tools/qtestlib/src/*_p.h ${D}/${QTHEADERDIR}/QtTest/private
+
+       keepdir "${QTSYSCONFDIR}"
+
+       sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.la
+       sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
+       sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.pc
+
+       # Move .pc files into the pkgconfig directory
+       dodir ${QTPCDIR}
+       mv ${D}/${QTLIBDIR}/*.pc ${D}/${QTPCDIR}
+
+       # List all the multilib libdirs
+       local libdirs
+       for libdir in $(get_all_libdirs); do
+               libdirs="${libdirs}:/usr/${libdir}/qt4"
+       done
+
+       cat > "${T}/44qt4" << EOF
+LDPATH=${libdirs:1}
+QMAKESPEC=$(qt_mkspecs_dir)
+EOF
+       doenvd "${T}/44qt4"
+}