Make USE="-alsa oss" work, thanks to Christophe PEREZ <chris@novazur.fr> in bug 127677
authorStefan Schweizer <genstef@gentoo.org>
Tue, 6 Jun 2006 18:50:13 +0000 (18:50 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Tue, 6 Jun 2006 18:50:13 +0000 (18:50 +0000)
Package-Manager: portage-2.1_rc4-r3

dev-libs/pwlib/ChangeLog
dev-libs/pwlib/pwlib-1.10.1.ebuild

index 8fbdc5445b8f05adac0b8f924086d4fa11d51068..bdb8d26373df5ec89a317d59ff45180c63b9a083 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-libs/pwlib
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/ChangeLog,v 1.96 2006/06/06 18:08:21 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/ChangeLog,v 1.97 2006/06/06 18:50:13 genstef Exp $
+
+  06 Jun 2006; Stefan Schweizer <genstef@gentoo.org> pwlib-1.10.1.ebuild:
+  Make USE="-alsa oss" work, thanks to Christophe PEREZ <chris@novazur.fr> in
+  bug 127677
 
 *pwlib-1.10.1 (06 Jun 2006)
 
index f10d62c7ccddf7676d73c62f8c472cd3acb2b044..6928c6b81872b822089bda02e7d0227dba221a2f 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.10.1.ebuild,v 1.1 2006/06/06 18:08:21 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.10.1.ebuild,v 1.2 2006/06/06 18:50:13 genstef Exp $
 
 inherit eutils flag-o-matic multilib
 
@@ -54,8 +54,11 @@ src_unpack() {
 }
 
 src_compile() {
+       local myconf=""
        # may cause ICE (bug #70638)
        filter-flags -fstack-protector
+       # disable-alsa breaks oss, see bug 127677
+       use alsa && myconf="--enable-alsa"
 
        econf \
                --enable-plugins \
@@ -64,7 +67,6 @@ src_compile() {
                $(use_enable ieee1394 dc) \
                $(use_enable ieee1394 avc) \
                $(use_enable oss) \
-               $(use_enable alsa) \
                $(use_enable ipv6) \
                $(use_enable sdl) \
                $(use_enable ssl openssl) \
@@ -73,6 +75,7 @@ src_compile() {
                $(use_enable ldap openldap) \
                $(use_enable sasl) \
                $(use_enable xml expat) \
+               ${myconf} \
                || die "configure failed"
 
        # Horrible hack to strip out -L/usr/lib to allow upgrades