dev-python/watchdog: Python 3.8
authorSebastian Pipping <sping@gentoo.org>
Sat, 7 Mar 2020 17:45:00 +0000 (18:45 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 7 Mar 2020 17:56:30 +0000 (18:56 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/watchdog/watchdog-0.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/watchdog/watchdog-0.9.0-r1.ebuild b/dev-python/watchdog/watchdog-0.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..4e9cf06
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       dev-python/argh[${PYTHON_USEDEP}]
+       dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+       test? ( >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+       default
+       rm tox.ini || die
+}
+
+pkg_postinst() {
+       optfeature "Bash completion" dev-python/argcomplete
+}