dev-ml/camlp5: ocaml version upper bound
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Sun, 13 Oct 2019 16:45:43 +0000 (18:45 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 20 Oct 2019 11:40:00 +0000 (13:40 +0200)
Closes: https://github.com/gentoo/gentoo/pull/13275
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Signed-off-by: David Seifert <soap@gentoo.org>
dev-ml/camlp5/camlp5-6.17.ebuild
dev-ml/camlp5/camlp5-7.00.ebuild
dev-ml/camlp5/camlp5-7.01.ebuild
dev-ml/camlp5/camlp5-7.03.ebuild

index 9f3df08d5fbed467c68538d88701a3e5b28cc543..96b44eda917050262c84e84c43983a6e7524a477 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -16,7 +16,10 @@ SLOT="0/${PV}"
 KEYWORDS="alpha amd64 ppc x86"
 IUSE="doc +ocamlopt"
 
-DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+DEPEND="
+       >=dev-lang/ocaml-3.10:=[ocamlopt?]
+       <=dev-lang/ocaml-4.4.2
+"
 RDEPEND="${DEPEND}"
 
 PATCHLEVEL=${PV#*_p}
@@ -44,7 +47,7 @@ src_configure() {
        ./configure \
                --strict \
                -prefix /usr \
-           -bindir /usr/bin \
+               -bindir /usr/bin \
                -libdir /usr/$(get_libdir)/ocaml \
                -mandir /usr/share/man || die "configure failed"
 }
index 547a32353afb19b6ae0124aaf7abb9c60449a131..2ead52bac719ee4721c863bb469adeed33ef80bc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -16,7 +16,10 @@ SLOT="0/${PV}"
 KEYWORDS="~alpha ~amd64 ~ppc ~x86"
 IUSE="doc +ocamlopt"
 
-DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+DEPEND="
+       >=dev-lang/ocaml-3.10:=[ocamlopt?]
+       <=dev-lang/ocaml-4.6.0
+"
 RDEPEND="${DEPEND}"
 
 PATCHLEVEL=${PV#*_p}
@@ -40,7 +43,7 @@ src_configure() {
        ./configure \
                --strict \
                -prefix /usr \
-           -bindir /usr/bin \
+               -bindir /usr/bin \
                -libdir /usr/$(get_libdir)/ocaml \
                -mandir /usr/share/man || die "configure failed"
 }
index 547a32353afb19b6ae0124aaf7abb9c60449a131..2ead52bac719ee4721c863bb469adeed33ef80bc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -16,7 +16,10 @@ SLOT="0/${PV}"
 KEYWORDS="~alpha ~amd64 ~ppc ~x86"
 IUSE="doc +ocamlopt"
 
-DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+DEPEND="
+       >=dev-lang/ocaml-3.10:=[ocamlopt?]
+       <=dev-lang/ocaml-4.6.0
+"
 RDEPEND="${DEPEND}"
 
 PATCHLEVEL=${PV#*_p}
@@ -40,7 +43,7 @@ src_configure() {
        ./configure \
                --strict \
                -prefix /usr \
-           -bindir /usr/bin \
+               -bindir /usr/bin \
                -libdir /usr/$(get_libdir)/ocaml \
                -mandir /usr/share/man || die "configure failed"
 }
index 547a32353afb19b6ae0124aaf7abb9c60449a131..2ead52bac719ee4721c863bb469adeed33ef80bc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -16,7 +16,10 @@ SLOT="0/${PV}"
 KEYWORDS="~alpha ~amd64 ~ppc ~x86"
 IUSE="doc +ocamlopt"
 
-DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+DEPEND="
+       >=dev-lang/ocaml-3.10:=[ocamlopt?]
+       <=dev-lang/ocaml-4.6.0
+"
 RDEPEND="${DEPEND}"
 
 PATCHLEVEL=${PV#*_p}
@@ -40,7 +43,7 @@ src_configure() {
        ./configure \
                --strict \
                -prefix /usr \
-           -bindir /usr/bin \
+               -bindir /usr/bin \
                -libdir /usr/$(get_libdir)/ocaml \
                -mandir /usr/share/man || die "configure failed"
 }