sys-apps/systemd: disable sysv init script sync
authorMike Gilbert <floppym@gentoo.org>
Mon, 27 Apr 2020 14:26:44 +0000 (10:26 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 27 Apr 2020 14:40:51 +0000 (10:40 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-apps/systemd/files/gentoo-systemctl-disable-sysv-sync.patch [new file with mode: 0644]
sys-apps/systemd/systemd-245-r5.ebuild [moved from sys-apps/systemd/systemd-245-r4.ebuild with 99% similarity]
sys-apps/systemd/systemd-9999.ebuild

diff --git a/sys-apps/systemd/files/gentoo-systemctl-disable-sysv-sync.patch b/sys-apps/systemd/files/gentoo-systemctl-disable-sysv-sync.patch
new file mode 100644 (file)
index 0000000..d92d2d4
--- /dev/null
@@ -0,0 +1,25 @@
+From 7ccd5724afc6fa83ec6cd93dbaf4faf3671c88fc Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Mon, 27 Apr 2020 10:22:03 -0400
+Subject: [PATCH] systemctl: disable synchronizaion of sysv init scripts
+
+---
+ src/systemctl/systemctl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/systemctl/systemctl.c b/src/systemctl/systemctl.c
+index d319d5d375..bb8419800c 100644
+--- a/src/systemctl/systemctl.c
++++ b/src/systemctl/systemctl.c
+@@ -6622,7 +6622,7 @@ static int import_environment(int argc, char *argv[], void *userdata) {
+ static int enable_sysv_units(const char *verb, char **args) {
+         int r = 0;
+-#if HAVE_SYSV_COMPAT
++#if 0
+         _cleanup_(lookup_paths_free) LookupPaths paths = {};
+         unsigned f = 0;
+-- 
+2.26.2
+
similarity index 99%
rename from sys-apps/systemd/systemd-245-r4.ebuild
rename to sys-apps/systemd/systemd-245-r5.ebuild
index b686b0a738b6ec02c5ee5b0ac794b5ea1a1f4a80..46c7844250b6d4b8b936a7d676ff0f6ba760137b 100644 (file)
@@ -209,6 +209,7 @@ src_prepare() {
                        "${FILESDIR}/gentoo-Dont-enable-audit-by-default.patch"
                        "${FILESDIR}/gentoo-systemd-user-pam.patch"
                        "${FILESDIR}/gentoo-generator-path-r1.patch"
+                       "${FILESDIR}/gentoo-systemctl-disable-sysv-sync.patch"
                )
        fi
 
index c692b2d9f5dccecdef71c51cfe78fdeaf009b9df..b755eb2883ee1c7ac0f48089e473e2a19d905909 100644 (file)
@@ -208,6 +208,7 @@ src_prepare() {
                        "${FILESDIR}/gentoo-Dont-enable-audit-by-default.patch"
                        "${FILESDIR}/gentoo-systemd-user-pam.patch"
                        "${FILESDIR}/gentoo-generator-path-r2.patch"
+                       "${FILESDIR}/gentoo-systemctl-disable-sysv-sync.patch"
                )
        fi