sci-libs/camd: new version 2.4.6.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 29 Feb 2020 01:55:28 +0000 (20:55 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Mon, 2 Mar 2020 17:20:43 +0000 (12:20 -0500)
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is
part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey
whose sage-on-gentoo ebuilds I'm using. There's a newer release
(v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-libs/camd/Manifest
sci-libs/camd/camd-2.4.6.ebuild [new file with mode: 0644]

index db90d85d89584ff75add705f725b23dfdf974881..e4e03474d03cf09a529ec8b1b3c5c1ce54b0ca69 100644 (file)
@@ -1 +1,2 @@
 DIST camd-2.3.1.tar.bz2 319766 BLAKE2B f812b457ede3b86fd7fd99f8cc2ea8f19a917c96cf33ca65c6bb2d0f7ebdb37b08af5cd8ad260bf4a636f2d884527c928c026edab23fffacafdd87ef2ce416e8 SHA512 13c5d687b9314f43a6c7237c7541e0c21cc544ffe52f8a984f64c5177a9f1f6b5ab07e9190388587f273424db8e6076ef050f836dbc9f33ca44e94d0034c8070
+DIST camd-2.4.6.tar.bz2 317071 BLAKE2B 8f982050a20f00c9443063a0473caa4aa27efe005fe07b503cb68b29499152561fc9d30d00783607b1e8fb8af88707eabfe22d192b80e375b8a6d04d7a9a26d7 SHA512 c4020ed3e063d04f5d7d1a301719b1a5b5b912d505858f046654c9d283c41ff01d55f668fb7f7179a6ac636f5a5b80f71cac5eb5b1e5cae0ede97d946d62a1d0
diff --git a/sci-libs/camd/camd-2.4.6.ebuild b/sci-libs/camd/camd-2.4.6.ebuild
new file mode 100644 (file)
index 0000000..3bdd531
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+BDEPEND="virtual/pkgconfig
+       doc? ( virtual/latex-base )"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       econf \
+               $(use_with doc) \
+               $(use_enable static-libs static)
+}