x11-plugins/wmtime: version bump
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Aug 2015 17:32:26 +0000 (19:32 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Aug 2015 17:32:55 +0000 (19:32 +0200)
Package-Manager: portage-2.2.20.1

x11-plugins/wmtime/Manifest
x11-plugins/wmtime/wmtime-1.4.ebuild [new file with mode: 0644]

index 80a84d07753d111ffd0cb76b773ccb0f55d5fa29..4c6932f5fb83abe87b0113037d3a32f94cd8b98e 100644 (file)
@@ -1,3 +1,4 @@
 DIST wmtime-1.2.tar.gz 23219 SHA256 ff39675d2c51e1d0774bdc181f27966fcf8f063bb0a4c8cfda9c83d9978a0b1a SHA512 d81be07012a9efd93a51219d6b63a76d88c8916af0b3ed990c3005621f643c70fadc31ebc8fef11c1605f303bc3e036c2014809c5368f4acaff8b7a1c1665c15 WHIRLPOOL 18067140573474c6b5ad3d01c00b353b55e6caee05cf474e0daf9483b9cab58df4d6dfcecbca53cc6015417f122f8ae920277359de682c7b9943ed09e8368b55
+DIST wmtime-1.4.tar.gz 19200 SHA256 6a112a2c7e22002b2c9d69479b95d4bae0ea29b310da71e612f540300c6def04 SHA512 46e35ffe41aaa55a651fa2a4002ab83fd45f901dc12ce1e0ed981666b9b620aa11666920f595fc3a782c54cc036491e0c676fb760a38cd6f6b24e264723b87fb WHIRLPOOL a8a300e5110ca0ae24d725c0c40d0b893047d5d450ba2d861898c7a47063efc9756fe2f32c7e5850d56f81653b07806a3ce6bf223d7dd01c8cc681eff06081ee
 DIST wmtime_1.0b2-9.diff.gz 8234 SHA256 189512286950bd5f8ab41d41c3ccbeee8811be95519ef9b03b12aeadded8312d
 DIST wmtime_1.0b2.orig.tar.gz 20483 SHA256 a526b95a16b8451ee9a05b57d97251e3d9efd5e7b7143d3592767b87a3941375
diff --git a/x11-plugins/wmtime/wmtime-1.4.ebuild b/x11-plugins/wmtime/wmtime-1.4.ebuild
new file mode 100644 (file)
index 0000000..b5a5560
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmtime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXau
+       x11-libs/libXdmcp
+       x11-libs/libXpm"
+DEPEND="${RDEPEND}
+       x11-proto/xproto"
+
+src_compile() {
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+       emake DESTDIR="${D}" PREFIX=/usr install
+
+       dodoc BUGS CHANGES HINTS README TODO
+}