dev-python/cbor2: New pkg, new dep of dev-python/autobahn-20.4.3
authorBrian Dolbec <dolsen@gentoo.org>
Fri, 8 May 2020 23:59:01 +0000 (16:59 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Sat, 9 May 2020 00:50:50 +0000 (17:50 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-python/cbor2/Manifest [new file with mode: 0644]
dev-python/cbor2/cbor2-5.1.0.ebuild [new file with mode: 0644]
dev-python/cbor2/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
new file mode 100644 (file)
index 0000000..bb524ad
--- /dev/null
@@ -0,0 +1 @@
+DIST cbor2-5.1.0.tar.gz 72328 BLAKE2B 22737f1ce152eb356fc937199ba83e9558b68900f8183ee8acca52312fa56499812d6b26aaaa629b6e2cfacbdfbb72f65cb7fcbe93a010320aff94aec8dc3978 SHA512 0df4f0c5609ae8d73627a64ee1544af88461b2bf829538f23d912138cf47ae8d03193644c7315e2a77318e58fd2bd61c4cb103d94ed0710db0ae5c2cf4df60b7
diff --git a/dev-python/cbor2/cbor2-5.1.0.ebuild b/dev-python/cbor2/cbor2-5.1.0.ebuild
new file mode 100644 (file)
index 0000000..0a40842
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPENDS="
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+       )
+"
+
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cbor2/metadata.xml b/dev-python/cbor2/metadata.xml
new file mode 100644 (file)
index 0000000..77d7b55
--- /dev/null
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+       </maintainer>
+       <upstream>
+               <maintainer>
+                       <email>bolson@bolson.org</email>
+                       <name>Brian Olson</name>
+               </maintainer>
+               <remote-id type="pypi">cbor</remote-id>
+               <remote-id type="bitbucket">bodhisnarkva/cbor</remote-id>
+       </upstream>
+       <longdescription>This library provides encoding and decoding for the
+Concise Binary Object Representation (CBOR) (RFC 7049) serialization format.
+It is implemented in pure python with an optional C backend and is compatible
+with versions 2.7 through to 3.8.  On cPython>=3.3 cbor2 can use a built in C
+module for performance similar to how pickle wraps the _pickle C module in the
+Python Standard Library.
+       </longdescription>
+</pkgmetadata>