x11-misc/libinput-gestures: version bump to 2.38, fix license
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>
Sun, 2 Sep 2018 15:57:39 +0000 (18:57 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Oct 2018 09:10:17 +0000 (11:10 +0200)
1. Fix license.
2. Remove test phase.
3. PYTHON_COMPAT for 3.7

Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua>
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/9766

x11-misc/libinput-gestures/Manifest
x11-misc/libinput-gestures/libinput-gestures-2.36.ebuild
x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild [new file with mode: 0644]
x11-misc/libinput-gestures/libinput-gestures-9999.ebuild

index 1a33f57039134b96df09d5fbf18480fec77e93a4..00d7a9151d13f26377bacd3a2fd696b60f86fd7d 100644 (file)
@@ -1 +1,2 @@
 DIST libinput-gestures-2.36.tar.gz 16598 BLAKE2B 3c30408ce394cf8bbc5a68c5f37c9106bb481ad47c75f25bfbba7470da0cbfb330512fe0422588408f177085c23a5cf0379c13a49c9fce438e8d8b1179c91d50 SHA512 69f77d0681f37deee3f215e71e4410d5c45107d2d0a1addb897de14d7f83bcb3e2285ed9ba605f30db23441a9d7bc9a6960b2a49d53ad71a379d0b874d36d645
+DIST libinput-gestures-2.38.tar.gz 17054 BLAKE2B 037d095674df9b00c9d23762745d35beaab03d0f5b361030a9177f84c540ef2ef45fb6fa4b9fe80a6500c81a8973aac46019931d8a548b02a6527ba09ca1fc13 SHA512 3152bcb0fd78551be14dda23fdce9f9216fc56e7a2dc4734b73949b4bd9c87fe6c9e2fc95f65a328b46c577abc05889a3a6290c6eb9390a94d9eb254c2fc7550
index 39fb049c736d572f665357202d3f70f45d29c9c1..a2cf956e87dbd776cdc7053f15d4cc791b1c0505 100644 (file)
@@ -17,10 +17,11 @@ else
        KEYWORDS="~amd64 ~x86"
 fi
 
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
 SLOT="0"
 IUSE="test"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
 
 RDEPEND="${PYTHON_DEPS}
        >=dev-libs/libinput-1.8.0
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.38.ebuild
new file mode 100644 (file)
index 0000000..87acd61
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4..7} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+       SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       >=dev-libs/libinput-1.8.0
+       x11-misc/xdotool
+       x11-misc/wmctrl"
+DEPEND=">=dev-libs/libinput-1.8.0
+       dev-util/desktop-file-utils"
+
+src_prepare() {
+       default
+
+       # Fix docdir installation path
+       sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
+}
+
+src_test() { :; }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+
+       elog "You must be in the input group to read the touchpad device."
+
+       if ! has_version x11-libs/gtk+:3 ; then
+               elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+       fi
+       if ! has_version kde-plasma/kde-cli-tools:5 ; then
+               elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+       fi
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}
index 39fb049c736d572f665357202d3f70f45d29c9c1..87acd61314540f621795720513c6dd0b34957904 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_COMPAT=( python3_{4..7} )
 
 inherit gnome2-utils python-single-r1
 
@@ -17,9 +17,9 @@ else
        KEYWORDS="~amd64 ~x86"
 fi
 
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
 SLOT="0"
-IUSE="test"
+IUSE=""
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
@@ -27,8 +27,7 @@ RDEPEND="${PYTHON_DEPS}
        x11-misc/xdotool
        x11-misc/wmctrl"
 DEPEND=">=dev-libs/libinput-1.8.0
-       dev-util/desktop-file-utils
-       test? ( dev-python/flake8[${PYTHON_USEDEP}] )"
+       dev-util/desktop-file-utils"
 
 src_prepare() {
        default
@@ -37,6 +36,8 @@ src_prepare() {
        sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
 }
 
+src_test() { :; }
+
 pkg_postinst() {
        gnome2_icon_cache_update