dev-python/snakeoil: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Sat, 30 May 2020 06:44:25 +0000 (08:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 30 May 2020 07:12:06 +0000 (09:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/snakeoil/files/snakeoil-0.8.8-py39.patch [new file with mode: 0644]
dev-python/snakeoil/snakeoil-0.8.8.ebuild
dev-python/snakeoil/snakeoil-9999.ebuild

diff --git a/dev-python/snakeoil/files/snakeoil-0.8.8-py39.patch b/dev-python/snakeoil/files/snakeoil-0.8.8-py39.patch
new file mode 100644 (file)
index 0000000..dbda88b
--- /dev/null
@@ -0,0 +1,28 @@
+From eeb1f45216eced42b386d6ea65eadc49798c7174 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 28 May 2020 14:00:34 +0200
+Subject: [PATCH] test_obj: Ignore __class_getitem__
+
+Ignore __class_getitem__ special that was added to some stdlib objects
+in Python 3.9.  It is used as part of type declarations.
+---
+ tests/module/test_obj.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/module/test_obj.py b/tests/module/test_obj.py
+index 03b100c..43c5c47 100644
+--- a/tests/module/test_obj.py
++++ b/tests/module/test_obj.py
+@@ -23,7 +23,8 @@ class TestDelayedInstantiation:
+         def assertKls(cls, ignores=(),
+                       default_ignores=("__new__", "__init__", "__init_subclass__",
+                                        "__getattribute__", "__class__",
+-                                       "__getnewargs__", "__doc__")):
++                                       "__getnewargs__", "__doc__",
++                                       "__class_getitem__")):
+             required = set(x for x in dir(cls)
+                            if x.startswith("__") and x.endswith("__"))
+             missing = required.difference(obj.kls_descriptors)
+-- 
+2.26.2
+
index c762561aef96e18f9295c9dcd15e8aaa0ba7d148..72c91229bc3c1e013f029b51b11a9da1587abd7f 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
 PYTHON_REQ_USE="threads(+)"
 inherit distutils-r1
 
@@ -27,6 +27,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
 "
 [[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-py39.patch
+)
+
 python_test() {
        esetup.py test
 }
index 1b7261487c4b716244da6689077ed4ffcf5e2ebc..68c9d15096042b931125be8c6d544ee979e1da76 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
 PYTHON_REQ_USE="threads(+)"
 inherit distutils-r1