app-eselect/eselect-php: new version 0.9.5.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 13 Apr 2018 17:53:38 +0000 (13:53 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 13 Apr 2018 17:56:16 +0000 (13:56 -0400)
Closes: https://bugs.gentoo.org/649270
Package-Manager: Portage-2.3.24, Repoman-2.3.6

app-eselect/eselect-php/Manifest
app-eselect/eselect-php/eselect-php-0.9.5.ebuild [new file with mode: 0644]

index 14647d6cf88f1141ec34ea58a6497be8fe9f21f9..9df9b294af3a345f26e4b036a2a5803a24667f63 100644 (file)
@@ -1,2 +1,3 @@
 DIST eselect-php-0.9.2.tar.xz 48356 BLAKE2B 9ad886b78c0a0ca71c1082d9265f28b1f9ea46dddfd52ad1a1ebb1a4d008954a59baf4cf69705e9b527fff64e8dfa3b25a2d522e2455e2e9ce550e917112ee58 SHA512 ebf4c9039aaa3ffad79dee181b5cd77f144a4b1b49d80291b290377b7ca5a9618d8b18922f0624e646c4d80266c58199bb936a7b8dd5d2e2bdc296099f583edf
 DIST eselect-php-0.9.4.tar.xz 49576 BLAKE2B 417956b355ffec7d7cda03dffa94e4d749a2b33a64a216c2ed8492181a5385f5219078efe6cc4d0d2d81b0fac40901c0cf07914a826484b83833542a12b47359 SHA512 2ba1dd75d4bb9611c6687ed4449f715728263538f772652aa1ac013103cf9ddf328c854326cf6da4f9b3ff2279bf99d973325520fe8b4e3ba7a76a9c3264e78e
+DIST eselect-php-0.9.5.tar.xz 49732 BLAKE2B 78c2010abcb1c9efd4d5f2f3f934365b338901a98bc8528131f2b9f564c1c3f740ab2dc2a28a0a58912e750062e61f75a7c6611c2f37019ca6525d729ffb5fd2 SHA512 55e401cb0c3ed19fed90485d62ba3deed3355503542898ff0d1b5404bd5fafb2f887df433609d4d4b28f32c0034100ea32c9e58547ef6417ea0b0f60d061d119
diff --git a/app-eselect/eselect-php/eselect-php-0.9.5.ebuild b/app-eselect/eselect-php/eselect-php-0.9.5.ebuild
new file mode 100644 (file)
index 0000000..7e46724
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+       apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+src_configure(){
+       # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+       # that's what PHP upstream expects. See for example the FPM
+       # configuration where they put logs in @localstatedir@/log.
+       #
+       # The libdir is passed explicitly in case the /usr/lib symlink
+       # is not present (bug 624528).
+       econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+                 --localstatedir="${EPREFIX}/var" \
+                 --with-piddir="${EPREFIX}/run" \
+                 $(use_enable apache2) \
+                 $(use_enable fpm)
+}
+
+src_install() {
+       default
+
+       if use fpm ; then
+               systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+               sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
+               exeinto /usr/libexec
+               doexe "${T}"/php-fpm-launcher
+       fi
+}