dev-python/oslo-reports: bup 1.17.1
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 6 Jul 2017 16:46:49 +0000 (11:46 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 6 Jul 2017 16:58:10 +0000 (11:58 -0500)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-python/oslo-reports/Manifest
dev-python/oslo-reports/oslo-reports-1.17.1.ebuild [new file with mode: 0644]

index 086722678e3700185bda5a409d43d5555b91bcb3..6de242787df9dd64a09f2a17c6846aa3332ee239 100644 (file)
@@ -1 +1,2 @@
 DIST oslo.reports-1.17.0.tar.gz 47891 SHA256 0f1b825ff32d0b36a1823116a2bddece1bbd17d8f85d8e8e5f8274df80d16852 SHA512 1fded7c8d6149dbbe11fb6fb28f6db656571519fcc093bfa7bf85a8d998c6cf23f28512e0658c9f8f547185f10bfb3b993fdc52942eac5ba884d2ee15556ad20 WHIRLPOOL 61f29933952e474aaac19f77a2165c14db0fc416b2d8e7d38351143dd4ca8af78f9652b099f18fa64ce898bb83a1bb217b97a7985b52dbd451f2cec297e32e77
+DIST oslo.reports-1.17.1.tar.gz 47828 SHA256 dbfc364f7d36065cfc369d98c01101f0833ef47f1786e1184296219067044792 SHA512 2ed6d69c8643901a185f38de34cff663160daa246d372503f17e2102634c6634dfafeaa7d6474b7bd702f43aece27a3e4d16c06ccc0a9f6bee1d79a2204ec704 WHIRLPOOL b10c8c8514963df3e87b4993d8419e48f065a1134ea938cf5f3d7e16b9cbea36e97209c1966def6ca79a43f77744a6a3760028a8ea7235531ef8241522f741c8
diff --git a/dev-python/oslo-reports/oslo-reports-1.17.1.ebuild b/dev-python/oslo-reports/oslo-reports-1.17.1.ebuild
new file mode 100644 (file)
index 0000000..62da8e1
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="generified reports for openstack"
+HOMEPAGE="http://docs.openstack.org/developer/oslo.reports"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.reports/oslo.reports-${PV}.tar.gz"
+S="${WORKDIR}/oslo.reports-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+       !~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
+       !~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
+       !~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
+       !~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
+       !~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}