dev-python/kombu: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Sun, 10 Jan 2016 08:23:35 +0000 (09:23 +0100)
committerJustin Lecher <jlec@gentoo.org>
Sun, 10 Jan 2016 08:23:41 +0000 (09:23 +0100)
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/kombu/Manifest
dev-python/kombu/kombu-3.0.33.ebuild [new file with mode: 0644]

index eaffc45930c02a826a3b7d6b9e6a604003a436a4..7aaa2201fa751a14ec255958d06ae5554e5964ca 100644 (file)
@@ -3,3 +3,4 @@ DIST kombu-3.0.26.tar.gz 375553 SHA256 1f565abd44c4b7dfaa4dd543d52f982d2f006aba0
 DIST kombu-3.0.29.tar.gz 378270 SHA256 970a55ec65e668403c3e6ef4aa2213362568387885f5cc0ff8429abd44a6dca8 SHA512 1093826ec4ba8234f8f8a1082252df20e600f0b58fc46c5c5b3ee6ef3b2582e2c986f997edfa13d4c85b9473236f3cca902375109266a809d33fd76c6eb45c35 WHIRLPOOL 9e4909c02ed2be14235861d2838278d71ab90da20f59c4b02123d9ce84212c0e93cc8b162e2ef8df45d224ed0166c022fca849a6cb39143fd6554e6a00b71893
 DIST kombu-3.0.30.tar.gz 380706 SHA256 b902fe768ea49173c7c26b117bf6c51d258f822d00d753e543b7e2285540f85a SHA512 91d43c7bf9902fe58b2a06f81286be81945c751ca4677a7ab9c78287e006726908b143510efcb4abf91b584f2fa0be7828df5631f552665fb3bbd9806f703075 WHIRLPOOL 75d62e8e395205157e1d018b6e20cc7f2b5ba0a7dd7ec40cfc21e0341aa9108eafd811277a0a9ed0fa6f1f41b9e96b7d1e8e4c32674e6db601b418afe6e70e3e
 DIST kombu-3.0.32.tar.gz 380958 SHA256 d3edda02076ae04fa62d128007756f4c4298fe479119ca070a47a22afe867660 SHA512 ffdccbdb9ddde28b5eb159dcc9697d48dddfbb1b74f9f9ced8eed92a25e53d21b5e2aa3a770b014397c73a92102a9d8dc9839bcdd1f49e1700fdfd79c5fcf022 WHIRLPOOL e7af358e76088039c8a407a2ea383208be4e4b5e37965dd88fae690dd7b7117829ac2d5c49f22374d8425f92a6c651520955526b1342dd7b5ed407d50f0d56d2
+DIST kombu-3.0.33.tar.gz 379423 SHA256 853d18ca958a598787ceb8c297a369745b82965bf28276861272f14745977999 SHA512 1f2772b79087038f5ec802fc8c1d511dc5e1de9bb663fb36878b5af4b0f925f83961e80a34f8a71af6d78fd45c719dfc62275923353ff38d06af5dae361f2059 WHIRLPOOL e55cdcaa550e1829b0d7cd00e03c63983f9a5525a6587428eabac6bc3379c1ba85e47173ffd14047edfc54f10391145c19fc0621074798fa7bb1e34b400f6fce
diff --git a/dev-python/kombu/kombu-3.0.33.ebuild b/dev-python/kombu/kombu-3.0.33.ebuild
new file mode 100644 (file)
index 0000000..5e0a228
--- /dev/null
@@ -0,0 +1,111 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="https://pypi.python.org/pypi/kombu https://github.com/celery/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="amqplib doc examples msgpack sqs test"
+
+# couchdb backend support possible via dev-python/couchdb-python
+# ditto dev-python/kazoo(>=1.3.1) and dev-python/beanstalkc
+PY27_GEN_USEDEP=$(python_gen_usedep python2_7)
+PYPY_GEN_USEDEP=$(python_gen_usedep python2_7 pypy)
+RDEPEND="
+       >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+       >=dev-python/py-amqp-1.4.9[${PYTHON_USEDEP}]
+       <dev-python/py-amqp-2.0[${PYTHON_USEDEP}]
+       dev-python/pyro:4[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]' 'python*')
+       amqplib? ( >=dev-python/amqplib-1.0.2[${PYTHON_USEDEP}] )
+       sqs? ( >=dev-python/boto-2.13.3[${PY27_GEN_USEDEP}] )
+       msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )"
+# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools-0.7[${PYTHON_USEDEP}]
+       test? (
+               >=dev-python/unittest2-0.5.0[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/nose-cover3[${PYTHON_USEDEP}]
+               >=dev-python/coverage-3.0[${PYTHON_USEDEP}]
+               >=dev-python/mock-0.7.0[${PYPY_GEN_USEDEP}]
+               dev-python/django[${PYTHON_USEDEP}]
+               >=dev-python/redis-py-2.10.3[${PYTHON_USEDEP}]
+               >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
+               >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/django[${PYTHON_USEDEP}]
+               dev-python/beanstalkc[${PY27_GEN_USEDEP}]
+               dev-python/couchdb-python[${PYTHON_USEDEP}]
+               >=dev-python/sphinxcontrib-issuetracker-0.9[${PYTHON_USEDEP}] )"
+
+# kazoo and sqlalchemy are optional packages for tests.
+# Refrain for now, no established demand for it from users
+
+# Req'd for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PY27_REQUSE="$(python_gen_useflags 'python2.7')"
+REQUIRED_USE="
+       sqs? ( ${PY27_REQUSE} )
+       doc? ( ${PY27_REQUSE} amqplib sqs )"    # 2 deps in doc build are py2 capable only
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-NA-tests-fix.patch
+       )
+
+pkg_setup() {
+       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
+python_prepare_all() {
+       # https://github.com/celery/kombu/issues/246
+       sed -e 's:kombu.transports:kombu.transport:' -i funtests/tests/test_django.py
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       # Doc build must be done by py2.7
+       # Doc build misses and skips only content re librabbitmq which is not in portage
+       if use doc; then
+               emake -C docs html || die "kombu docs failed installation"
+       fi
+}
+
+python_test() {
+       export DJANGO_SETTINGS_MODULE="django.conf"
+       # https://github.com/celery/kombu/issues/474
+       # tests need </pymongo-3.0; known to cause some breakage
+       if python_is_python3; then
+               2to3 --no-diffs -w build/lib/kombu/transport/
+               nosetests --py3where=build/lib kombu/tests || die "Tests failed under ${EPYTHON}"
+       else
+               nosetests "${S}"/kombu/tests || die "Tests failed under ${EPYTHON}"
+               # funtests appears to be coded only for py2, a kind of 2nd tier. pypy fails 6.
+               # https://github.com/celery/kombu/issues/411
+               # Fix to https://github.com/celery/kombu/issues/474 breaks the 
+               # funtests under >=dev-python/pymongo-3.0.2
+#              if [[ "${EPYTHON}" == python2.7 ]]; then
+#                      pushd funtests > /dev/null
+#                      esetup.py test
+#                      popd > /dev/null
+#              fi
+       fi
+}
+
+python_install_all() {
+       use examples && local EXAMPLES=( examples/. )
+       use doc && local HTML_DOCS=( docs/.build/html/. )
+       distutils-r1_python_install_all
+}