dev-perl/DBICx-TestDatabase: Fix for '.' in @INC re bug #615712
authorKent Fredric <kentnl@gentoo.org>
Sun, 25 Jun 2017 09:37:32 +0000 (21:37 +1200)
committerKent Fredric <kentnl@gentoo.org>
Sun, 25 Jun 2017 09:37:32 +0000 (21:37 +1200)
Generic Module::Install + 5.26 fix

Bug: https://bugs.gentoo.org/615712
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.40.0.ebuild
dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild

index f3433e222efdeec971b8fc192d32f25b1727b49f..fde967d2695898f126cd43f700cdf9a247983690 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -26,3 +26,9 @@ DEPEND="${RDEPEND}
 "
 
 SRC_TEST="do"
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}
index cf49bbea02575a45804af6abf3b6e1cc611b0e9b..1e043da5e0f4bf60b9d5b4e112bad5a40b74ef63 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -25,3 +25,9 @@ DEPEND="${RDEPEND}
        )
 "
 PERL_RM_FILES=("MYMETA.json" "MYMETA.yml") # https://rt.cpan.org/Ticket/Display.html?id=108141
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}