sys-apps/sed: pass --without-selinux to configure
authorMike Gilbert <floppym@gentoo.org>
Mon, 25 May 2020 15:53:53 +0000 (11:53 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 25 May 2020 15:53:53 +0000 (11:53 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-apps/sed/sed-4.8.ebuild

index 66b31632c461398d0bbda6b3d4064f756b7c878b..bada9c0a526c7c9c83a67bdc12211838e05523c0 100644 (file)
@@ -38,12 +38,11 @@ src_configure() {
                myconf+=( --program-prefix=g )
        fi
 
-       export ac_cv_search_setfilecon=$(usex selinux -lselinux)
-       export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
        use static && append-ldflags -static
        myconf+=(
                $(use_enable acl)
                $(use_enable nls)
+               $(use_with selinux)
        )
        econf "${myconf[@]}"
 }