sys-libs/libcxxabi: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:54 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:55 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libcxxabi/libcxxabi-10.0.0.9999.ebuild
sys-libs/libcxxabi/libcxxabi-9.0.1.9999.ebuild

index edc18f6fea904939c92b9711055fc919c2bacf0e..8a1fd469ee762cbe588c041347e1a922ca4c2d0e 100644 (file)
@@ -13,8 +13,8 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1
 DESCRIPTION="Low level support for a standard C++ library"
 HOMEPAGE="https://libcxxabi.llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxxabi.git
-       https://github.com/llvm-mirror/libcxxabi.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/libcxxabi
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="0"
@@ -49,14 +49,9 @@ pkg_setup() {
 }
 
 src_unpack() {
-       # we need the headers
-       git-r3_fetch "https://git.llvm.org/git/libcxx.git
-               https://github.com/llvm-mirror/libcxx.git"
        git-r3_fetch
-
-       git-r3_checkout https://llvm.org/git/libcxx.git \
-               "${WORKDIR}"/libcxx ''
-       git-r3_checkout
+       # we always need libcxx for the headers
+       git-r3_checkout '' '' '' libcxx{,abi}
 }
 
 multilib_src_configure() {
@@ -68,7 +63,7 @@ multilib_src_configure() {
                -DLIBCXXABI_USE_LLVM_UNWINDER=$(usex libunwind)
                -DLIBCXXABI_INCLUDE_TESTS=$(usex test)
 
-               -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}"/libcxx/include
+               -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}/${P}"/libcxx/include
                # upstream is omitting standard search path for this
                # probably because gcc & clang are bundling their own unwind.h
                -DLIBCXXABI_LIBUNWIND_INCLUDES="${EPREFIX}"/usr/include
@@ -89,7 +84,7 @@ multilib_src_configure() {
 
 build_libcxx() {
        local -x LDFLAGS="${LDFLAGS} -L${BUILD_DIR}/$(get_libdir)"
-       local CMAKE_USE_DIR=${WORKDIR}/libcxx
+       local CMAKE_USE_DIR=${WORKDIR}/${P}/libcxx
        local BUILD_DIR=${BUILD_DIR}/libcxx
        local mycmakeargs=(
                -DLIBCXX_LIBDIR_SUFFIX=
index 70fcb998c05d399e02db715815635b0668294e4a..591bf45eca848a7487eda11360b6e9f6de4522d0 100644 (file)
@@ -13,9 +13,9 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1
 DESCRIPTION="Low level support for a standard C++ library"
 HOMEPAGE="https://libcxxabi.llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxxabi.git
-       https://github.com/llvm-mirror/libcxxabi.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/libcxxabi
 
 LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
 SLOT="0"
@@ -50,14 +50,9 @@ pkg_setup() {
 }
 
 src_unpack() {
-       # we need the headers
-       git-r3_fetch "https://git.llvm.org/git/libcxx.git
-               https://github.com/llvm-mirror/libcxx.git"
        git-r3_fetch
-
-       git-r3_checkout https://llvm.org/git/libcxx.git \
-               "${WORKDIR}"/libcxx ''
-       git-r3_checkout
+       # we always need libcxx for the headers
+       git-r3_checkout '' '' '' libcxx{,abi}
 }
 
 multilib_src_configure() {
@@ -69,7 +64,7 @@ multilib_src_configure() {
                -DLIBCXXABI_USE_LLVM_UNWINDER=$(usex libunwind)
                -DLIBCXXABI_INCLUDE_TESTS=$(usex test)
 
-               -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}"/libcxx/include
+               -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}/${P}"/libcxx/include
                # upstream is omitting standard search path for this
                # probably because gcc & clang are bundling their own unwind.h
                -DLIBCXXABI_LIBUNWIND_INCLUDES="${EPREFIX}"/usr/include
@@ -90,7 +85,7 @@ multilib_src_configure() {
 
 build_libcxx() {
        local -x LDFLAGS="${LDFLAGS} -L${BUILD_DIR}/$(get_libdir)"
-       local CMAKE_USE_DIR=${WORKDIR}/libcxx
+       local CMAKE_USE_DIR=${WORKDIR}/${P}/libcxx
        local BUILD_DIR=${BUILD_DIR}/libcxx
        local mycmakeargs=(
                -DLIBCXX_LIBDIR_SUFFIX=