media-gfx/krita: Fix build with Qt 5.15
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 18 Apr 2020 19:15:43 +0000 (21:15 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 18 Apr 2020 19:32:48 +0000 (21:32 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/krita/Manifest
media-gfx/krita/files/krita-4.2.9-ecm-findopenexr.patch [deleted file]
media-gfx/krita/krita-4.2.9.ebuild

index 2bab9ddbf4a0414a4d9075a43c583fa8745cfb05..bf42126de168e0abe9b4395d52817053b8b45fc7 100644 (file)
@@ -1,3 +1,4 @@
 DIST krita-4.2.8.2-patchset.tar.xz 13848 BLAKE2B 86059e08833541b7d4dfda2c36cd1479809452171353b755ab3a264fa41fb99fc7ffacf064af3767aa095fda81aa9a2212b63c7242c72f94ca23a83b34c0502f SHA512 79532700c967f94479af22e2fbd33c0b6d8c4295c872316935800b99258dceaedbac2b1c6314251d4d621c25a328ea602f49d415cc9275095bc3cd2f29756a61
 DIST krita-4.2.8.2.tar.xz 169994064 BLAKE2B fc390db9e3aaf3f4355e600a98ea479aa510895c26cb82e8800fbff64031bab7a26e0c37d6d274e6397a38c1bc33cff6b48cb5a7c6e61b56579e92e33279b1c4 SHA512 5482ebd62c530764b43439d6782fa7e1793877657620967ea0f6cdad166e3ff508b36cd04bd99c192d35a237c4a0da08477069e333ebaf2093785e207402dea7
+DIST krita-4.2.9-patchset.tar.xz 7928 BLAKE2B 57256884edafd528cfca529e020a226613a37682df445ece24d434e816f218d822c03d668a13806f775d02757bafd9627ed8073406e5506023767d06c78c30de SHA512 36ec902afec082fcf18c0e523a83a08aa54d54bd5393691b0f17dcab0969e69973d8e842fac44fcf66232f369b36f97937f67b5c0b0bdcff019cc1d323b3bf59
 DIST krita-4.2.9.tar.xz 170082028 BLAKE2B dafe300a1ef56a743272ce5936a0640949b7cfd37322e30e8a7ef17c4e51bf9dc8175d1443f9943836a229933ecb9a5d28249b8c90155165f3f0ee800e3cfa66 SHA512 66eef3d1b5647e62551276662ef4332f15abc022f1032f27a2ad695a8d2dc5fa758146492a9da2b8cbd4a52e47c576473029d2aa9728dea3bec869b8173f08c0
diff --git a/media-gfx/krita/files/krita-4.2.9-ecm-findopenexr.patch b/media-gfx/krita/files/krita-4.2.9-ecm-findopenexr.patch
deleted file mode 100644 (file)
index 0a7c7ca..0000000
+++ /dev/null
@@ -1,352 +0,0 @@
-From dae9ddcd45a95fd3b1ec3d42510556a671b08f15 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Tue, 31 Mar 2020 19:56:48 +0200
-Subject: [PATCH 1/2] Revert "Revert "Use e-c-m's findopenexr.cmake module""
-
-This reverts commit d978a33acebb724b862c38895788fc459111c364.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt                  |  2 +-
- cmake/modules/FindOpenEXR.cmake | 98 ---------------------------------
- 2 files changed, 1 insertion(+), 99 deletions(-)
- delete mode 100644 cmake/modules/FindOpenEXR.cmake
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a7d9adaa3f..7a4211da13 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -251,7 +251,7 @@ endif(MINGW)
- ########################
- find_package(ECM 5.22 REQUIRED NOMODULE)
--set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
-+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} ${ECM_FIND_MODULE_DIR})
- include(ECMOptionalAddSubdirectory)
- include(ECMAddAppIcon)
- include(ECMSetupVersion)
-diff --git a/cmake/modules/FindOpenEXR.cmake b/cmake/modules/FindOpenEXR.cmake
-deleted file mode 100644
-index bb75a03bf0..0000000000
---- a/cmake/modules/FindOpenEXR.cmake
-+++ /dev/null
-@@ -1,98 +0,0 @@
--#
--# Copyright 2016 Pixar
--#
--# Licensed under the Apache License, Version 2.0 (the "Apache License")
--# with the following modification; you may not use this file except in
--# compliance with the Apache License and the following modification to it:
--# Section 6. Trademarks. is deleted and replaced with:
--#
--# 6. Trademarks. This License does not grant permission to use the trade
--#    names, trademarks, service marks, or product names of the Licensor
--#    and its affiliates, except as required to comply with Section 4(c) of
--#    the License and to reproduce the content of the NOTICE file.
--#
--# You may obtain a copy of the Apache License at
--#
--#     http://www.apache.org/licenses/LICENSE-2.0
--#
--# Unless required by applicable law or agreed to in writing, software
--# distributed under the Apache License with the above modification is
--# distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
--# KIND, either express or implied. See the Apache License for the specific
--# language governing permissions and limitations under the Apache License.
--#
--
--find_path(OPENEXR_INCLUDE_DIR
--    OpenEXR/half.h
--HINTS
--    "${OPENEXR_LOCATION}"
--    "$ENV{OPENEXR_LOCATION}"
--PATH_SUFFIXES
--    include/
--DOC
--    "OpenEXR headers path"
--)
--
--if(OPENEXR_INCLUDE_DIR)
--  set(openexr_config_file "${OPENEXR_INCLUDE_DIR}/OpenEXR/OpenEXRConfig.h")
--  if(EXISTS ${openexr_config_file})
--      file(STRINGS
--           ${openexr_config_file}
--           TMP
--           REGEX "#define OPENEXR_VERSION_STRING.*$")
--      string(REGEX MATCHALL "[0-9.]+" OPENEXR_VERSION ${TMP})
--
--      file(STRINGS
--           ${openexr_config_file}
--           TMP
--           REGEX "#define OPENEXR_VERSION_MAJOR.*$")
--      string(REGEX MATCHALL "[0-9]" OPENEXR_MAJOR_VERSION ${TMP})
--
--      file(STRINGS
--           ${openexr_config_file}
--           TMP
--           REGEX "#define OPENEXR_VERSION_MINOR.*$")
--      string(REGEX MATCHALL "[0-9]" OPENEXR_MINOR_VERSION ${TMP})
--  endif()
--endif()
--
--foreach(OPENEXR_LIB
--    Half
--    Iex
--    Imath
--    IlmImf
--    IlmThread
--    )
--
--    # OpenEXR libraries may be suffixed with the version number, so we search
--    # using both versioned and unversioned names.
--    find_library(OPENEXR_${OPENEXR_LIB}_LIBRARY
--        NAMES
--            ${OPENEXR_LIB}-${OPENEXR_MAJOR_VERSION}_${OPENEXR_MINOR_VERSION}
--            ${OPENEXR_LIB}
--        HINTS
--            "${OPENEXR_LOCATION}"
--            "$ENV{OPENEXR_LOCATION}"
--        PATH_SUFFIXES
--            lib/
--        DOC
--            "OPENEXR's ${OPENEXR_LIB} library path"
--    )
--
--    if(OPENEXR_${OPENEXR_LIB}_LIBRARY)
--        list(APPEND OPENEXR_LIBRARIES ${OPENEXR_${OPENEXR_LIB}_LIBRARY})
--    endif()
--endforeach(OPENEXR_LIB)
--
--# So #include <half.h> works
--list(APPEND OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR})
--list(APPEND OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR}/OpenEXR)
--
--include(FindPackageHandleStandardArgs)
--find_package_handle_standard_args(OpenEXR
--    REQUIRED_VARS
--        OPENEXR_INCLUDE_DIRS
--        OPENEXR_LIBRARIES
--    VERSION_VAR
--        OPENEXR_VERSION
--)
--- 
-2.26.0
-
-
-From b6e1c9c015989c47688c3cc3efa85e51eb02696f Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Thu, 2 Apr 2020 14:49:10 +0200
-Subject: [PATCH 2/2] For ECM FindOpenEXR.cmake, in CMakeLists.txt, do
- s/OPENEXR/OpenEXR/
-
----
- CMakeLists.txt                                       |  8 ++++----
- libs/image/CMakeLists.txt                            |  4 ++--
- libs/pigment/CMakeLists.txt                          |  6 +++---
- libs/ui/CMakeLists.txt                               |  2 +-
- plugins/color/colorspaceextensions/CMakeLists.txt    |  2 +-
- plugins/color/lcms2engine/CMakeLists.txt             | 10 +++++-----
- plugins/color/lcms2engine/tests/CMakeLists.txt       |  4 ++--
- plugins/dockers/specificcolorselector/CMakeLists.txt |  2 +-
- plugins/impex/CMakeLists.txt                         |  2 +-
- plugins/impex/exr/CMakeLists.txt                     |  6 +++---
- plugins/impex/raw/CMakeLists.txt                     |  4 ++--
- 11 files changed, 25 insertions(+), 25 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7a4211da13..5ff18bbb17 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -571,11 +571,11 @@ set_package_properties(OpenEXR PROPERTIES
-     URL "http://www.openexr.com"
-     TYPE OPTIONAL
-     PURPOSE "Required by the Krita OpenEXR filter")
--macro_bool_to_01(OPENEXR_FOUND HAVE_OPENEXR)
-+macro_bool_to_01(OpenEXR_FOUND HAVE_OPENEXR)
- set(LINK_OPENEXR_LIB)
--if(OPENEXR_FOUND)
--    include_directories(SYSTEM ${OPENEXR_INCLUDE_DIRS})
--    set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES})
-+if(OpenEXR_FOUND)
-+    include_directories(SYSTEM ${OpenEXR_INCLUDE_DIRS})
-+    set(LINK_OPENEXR_LIB ${OpenEXR_LIBRARIES})
-     add_definitions(${OPENEXR_DEFINITIONS})
- endif()
-diff --git a/libs/image/CMakeLists.txt b/libs/image/CMakeLists.txt
-index 6d7c6a4daa..74d78103ab 100644
---- a/libs/image/CMakeLists.txt
-+++ b/libs/image/CMakeLists.txt
-@@ -349,8 +349,8 @@ if(NOT HAVE_CXX_ATOMICS_WITHOUT_LIB)
-     endif()
- endif()
--if(OPENEXR_FOUND)
--  target_link_libraries(kritaimage PUBLIC ${OPENEXR_LIBRARIES})
-+if(OpenEXR_FOUND)
-+  target_link_libraries(kritaimage PUBLIC ${OpenEXR_LIBRARIES})
- endif()
- if(FFTW3_FOUND)
-diff --git a/libs/pigment/CMakeLists.txt b/libs/pigment/CMakeLists.txt
-index 2a574a6c77..53e34cc029 100644
---- a/libs/pigment/CMakeLists.txt
-+++ b/libs/pigment/CMakeLists.txt
-@@ -14,9 +14,9 @@ include_directories(
- set(FILE_OPENEXR_SOURCES)
- set(LINK_OPENEXR_LIB)
--if(OPENEXR_FOUND)
--    include_directories(SYSTEM ${OPENEXR_INCLUDE_DIRS})
--    set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES})
-+if(OpenEXR_FOUND)
-+    include_directories(SYSTEM ${OpenEXR_INCLUDE_DIRS})
-+    set(LINK_OPENEXR_LIB ${OpenEXR_LIBRARIES})
-     add_definitions(${OPENEXR_DEFINITIONS})
- endif()
-diff --git a/libs/ui/CMakeLists.txt b/libs/ui/CMakeLists.txt
-index 73f36e4e68..151c46f711 100644
---- a/libs/ui/CMakeLists.txt
-+++ b/libs/ui/CMakeLists.txt
-@@ -576,7 +576,7 @@ if(APPLE)
- endif ()
--target_link_libraries(kritaui ${OPENEXR_LIBRARIES})
-+target_link_libraries(kritaui ${OpenEXR_LIBRARIES})
- # Add VSync disable workaround
- if(NOT WIN32 AND NOT APPLE)
-diff --git a/plugins/color/colorspaceextensions/CMakeLists.txt b/plugins/color/colorspaceextensions/CMakeLists.txt
-index ee8033afed..523e11cfb9 100644
---- a/plugins/color/colorspaceextensions/CMakeLists.txt
-+++ b/plugins/color/colorspaceextensions/CMakeLists.txt
-@@ -12,5 +12,5 @@ set( extensions_plugin_SOURCES
- )
- add_library(krita_colorspaces_extensions MODULE ${extensions_plugin_SOURCES} )
--target_link_libraries(krita_colorspaces_extensions kritapigment kritaglobal ${OPENEXR_LIBRARIES} KF5::I18n KF5::CoreAddons)
-+target_link_libraries(krita_colorspaces_extensions kritapigment kritaglobal ${OpenEXR_LIBRARIES} KF5::I18n KF5::CoreAddons)
- install( TARGETS krita_colorspaces_extensions DESTINATION ${KRITA_PLUGIN_INSTALL_DIR} )
-diff --git a/plugins/color/lcms2engine/CMakeLists.txt b/plugins/color/lcms2engine/CMakeLists.txt
-index e14de2ba7c..109a708b2d 100644
---- a/plugins/color/lcms2engine/CMakeLists.txt
-+++ b/plugins/color/lcms2engine/CMakeLists.txt
-@@ -28,7 +28,7 @@ include_directories(
-     ${CMAKE_CURRENT_SOURCE_DIR}/colorprofiles
- )
--if (HAVE_LCMS24 AND OPENEXR_FOUND)
-+if (HAVE_LCMS24 AND OpenEXR_FOUND)
- include_directories( 
-     ${CMAKE_CURRENT_SOURCE_DIR}/colorspaces/gray_f16
-     ${CMAKE_CURRENT_SOURCE_DIR}/colorspaces/rgb_f16
-@@ -38,9 +38,9 @@ endif ()
- set(FILE_OPENEXR_SOURCES)
- set(LINK_OPENEXR_LIB)
--if(OPENEXR_FOUND)
--    include_directories(SYSTEM ${OPENEXR_INCLUDE_DIRS})
--    set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES})
-+if(OpenEXR_FOUND)
-+    include_directories(SYSTEM ${OpenEXR_INCLUDE_DIRS})
-+    set(LINK_OPENEXR_LIB ${OpenEXR_LIBRARIES})
-     add_definitions(${OPENEXR_DEFINITIONS})
- endif()
-@@ -77,7 +77,7 @@ set ( lcmsengine_SRCS
-     LcmsEnginePlugin.cpp
- )
--if (HAVE_LCMS24 AND OPENEXR_FOUND)
-+if (HAVE_LCMS24 AND OpenEXR_FOUND)
-     set ( lcmsengine_SRCS
-         ${lcmsengine_SRCS}
-         colorspaces/gray_f16/GrayF16ColorSpace.cpp
-diff --git a/plugins/color/lcms2engine/tests/CMakeLists.txt b/plugins/color/lcms2engine/tests/CMakeLists.txt
-index eea9e9e846..87ca907148 100644
---- a/plugins/color/lcms2engine/tests/CMakeLists.txt
-+++ b/plugins/color/lcms2engine/tests/CMakeLists.txt
-@@ -12,8 +12,8 @@ include_directories( ../colorspaces/cmyk_u16
-     ../colorprofiles
-     ..
- )
--if(OPENEXR_FOUND)
--    include_directories(SYSTEM ${OPENEXR_INCLUDE_DIRS})
-+if(OpenEXR_FOUND)
-+    include_directories(SYSTEM ${OpenEXR_INCLUDE_DIRS})
- endif()
- include_directories( ${LCMS2_INCLUDE_DIR} )
-diff --git a/plugins/dockers/specificcolorselector/CMakeLists.txt b/plugins/dockers/specificcolorselector/CMakeLists.txt
-index 97f7ab2cdd..214a46eaa9 100644
---- a/plugins/dockers/specificcolorselector/CMakeLists.txt
-+++ b/plugins/dockers/specificcolorselector/CMakeLists.txt
-@@ -10,5 +10,5 @@ ki18n_wrap_ui(KRITA_SPECIFICCOLORSELECTOR_SOURCES
- add_library(kritaspecificcolorselector MODULE ${KRITA_SPECIFICCOLORSELECTOR_SOURCES})
--target_link_libraries(kritaspecificcolorselector kritaui ${OPENEXR_LIBRARIES})
-+target_link_libraries(kritaspecificcolorselector kritaui ${OpenEXR_LIBRARIES})
- install(TARGETS kritaspecificcolorselector  DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
-diff --git a/plugins/impex/CMakeLists.txt b/plugins/impex/CMakeLists.txt
-index 51056ecf47..838f34b6eb 100644
---- a/plugins/impex/CMakeLists.txt
-+++ b/plugins/impex/CMakeLists.txt
-@@ -19,7 +19,7 @@ if(PNG_FOUND)
-     add_subdirectory(csv)
- endif()
--if(OPENEXR_FOUND)
-+if(OpenEXR_FOUND)
-     add_subdirectory(exr)
- endif()
-diff --git a/plugins/impex/exr/CMakeLists.txt b/plugins/impex/exr/CMakeLists.txt
-index aa39a91879..cb07f6b01a 100644
---- a/plugins/impex/exr/CMakeLists.txt
-+++ b/plugins/impex/exr/CMakeLists.txt
-@@ -1,6 +1,6 @@
- add_subdirectory(tests)
--include_directories(SYSTEM ${OPENEXR_INCLUDE_DIRS} )
-+include_directories(SYSTEM ${OpenEXR_INCLUDE_DIRS} )
- add_definitions(${OPENEXR_DEFINITIONS})
-@@ -17,7 +17,7 @@ set(kritaexrimport_SOURCES
- add_library(kritaexrimport MODULE ${kritaexrimport_SOURCES})
--target_link_libraries(kritaexrimport kritaui kritalibkra ${OPENEXR_LIBRARIES} )
-+target_link_libraries(kritaexrimport kritaui kritalibkra ${OpenEXR_LIBRARIES} )
- install(TARGETS kritaexrimport  DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
-@@ -30,7 +30,7 @@ ki18n_wrap_ui(kritaexrexport_SOURCES exr_export_widget.ui )
- add_library(kritaexrexport MODULE ${kritaexrexport_SOURCES})
--target_link_libraries(kritaexrexport kritaui kritalibkra kritaimpex ${OPENEXR_LIBRARIES} )
-+target_link_libraries(kritaexrexport kritaui kritalibkra kritaimpex ${OpenEXR_LIBRARIES} )
- install(TARGETS kritaexrexport  DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
-diff --git a/plugins/impex/raw/CMakeLists.txt b/plugins/impex/raw/CMakeLists.txt
-index 71cb5b355c..d20cbe63c5 100644
---- a/plugins/impex/raw/CMakeLists.txt
-+++ b/plugins/impex/raw/CMakeLists.txt
-@@ -1,7 +1,7 @@
- add_subdirectory(tests)
--if(OPENEXR_FOUND)
--      include_directories(${OPENEXR_INCLUDE_DIRS})
-+if(OpenEXR_FOUND)
-+      include_directories(${OpenEXR_INCLUDE_DIRS})
- endif()
- include_directories(${LibRaw_INCLUDE_DIR})
- include_directories(${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/libkdcraw/src)
--- 
-2.26.0
-
index 91a902cc8054c5952bc3232ed416b15fba45901a..e3e6c38ca03ac02cf307c796e65d4029f8e3d8b7 100644 (file)
@@ -11,7 +11,8 @@ VIRTUALX_REQUIRED="test"
 inherit ecm kde.org python-single-r1
 
 if [[ ${KDE_BUILD_TYPE} = release ]]; then
-       SRC_URI="mirror://kde/stable/${PN}/$(ver_cut 1-3)/${P}.tar.xz"
+       SRC_URI="mirror://kde/stable/${PN}/$(ver_cut 1-3)/${P}.tar.xz
+               https://dev.gentoo.org/~asturm/distfiles/${P}-patchset.tar.xz"
        KEYWORDS="~amd64 ~ppc64 ~x86"
 fi
 
@@ -89,7 +90,7 @@ RESTRICT+=" test"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-4.2.4-tests-optional.patch
-       "${FILESDIR}"/${P}-ecm-findopenexr.patch
+       "${WORKDIR}"/${P}-patchset
 )
 
 pkg_setup() {