dev-ml/ppx_enumerate: update to opam.eclass
authorAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:05:58 +0000 (10:05 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:31:34 +0000 (10:31 +0200)
Package-Manager: Portage-2.3.10, Repoman-2.3.3

dev-ml/ppx_enumerate/ppx_enumerate-0.9.0.ebuild

index 44a9ea0a28488d117cfc1488bcbe13afeb9ee9a5..64a8a340f0fd3e2fce29d111ff92c370a4e930d6 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI=6
 
+inherit opam
+
 DESCRIPTION="Generate a list containing all values of a finite type"
 HOMEPAGE="https://github.com/janestreet/ppx_enumerate"
 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -13,7 +15,6 @@ KEYWORDS="~amd64 ~ppc"
 IUSE=""
 
 DEPEND="
-       dev-lang/ocaml:=
        dev-ml/ppx_core:=
        dev-ml/ppx_driver:=
        dev-ml/ppx_metaquot:=
@@ -21,12 +22,4 @@ DEPEND="
        dev-ml/ocaml-migrate-parsetree:=
 "
 RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
-
-src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               ${PN}.install || die
-}
+DEPEND="${DEPEND} dev-ml/jbuilder"