sys-auth/keystone: migrate to user eclass
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 13 May 2020 22:44:50 +0000 (17:44 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 13 May 2020 22:45:09 +0000 (17:45 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-auth/keystone/keystone-16.0.1.ebuild

index 4494f24111e2a717a89d820964a19452cca6b651..f1cdd22c765a554d1e2f9fbb2c1280c41c55f645 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python3_{6,7} )
 
-inherit distutils-r1 user
+inherit distutils-r1
 
 DESCRIPTION="The Openstack authentication, authorization, and service catalog"
 HOMEPAGE="https://launchpad.net/keystone"
@@ -97,15 +97,9 @@ RDEPEND="
                www-servers/uwsgi[python,${PYTHON_USEDEP}]
                www-apache/mod_wsgi[${PYTHON_USEDEP}]
                www-servers/gunicorn[${PYTHON_USEDEP}]
-       )"
-
-#PATCHES=(
-#)
-
-pkg_setup() {
-       enewgroup keystone
-       enewuser keystone -1 -1 /var/lib/keystone keystone
-}
+       )
+       acct-user/keystone
+       acct-group/keystone"
 
 python_prepare_all() {
        # it's in git, but not in the tarball.....