dev-libs/redland: Fix building against mysql 8
authorDavid Seifert <soap@gentoo.org>
Thu, 20 Feb 2020 15:53:18 +0000 (16:53 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 20 Feb 2020 15:53:18 +0000 (16:53 +0100)
Closes: https://bugs.gentoo.org/692462
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Acked-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/redland/files/redland-1.0.17-mysql-8-my_bool.patch [new file with mode: 0644]
dev-libs/redland/redland-1.0.17-r2.ebuild

diff --git a/dev-libs/redland/files/redland-1.0.17-mysql-8-my_bool.patch b/dev-libs/redland/files/redland-1.0.17-mysql-8-my_bool.patch
new file mode 100644 (file)
index 0000000..a59c456
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/src/rdf_storage_mysql.c
++++ b/src/rdf_storage_mysql.c
+@@ -445,11 +445,11 @@
+   /* Initialize closed MySQL connection handle */
+   connection->handle=mysql_init(connection->handle);
+ #ifdef HAVE_MYSQL_OPT_RECONNECT
+   if(1) {
+-    my_bool value=(context->reconnect) ? 1 : 0;
++    bool value=(context->reconnect) ? 1 : 0;
+     mysql_options(connection->handle, MYSQL_OPT_RECONNECT, &value);
+   }
+ #endif
+   /* Create connection to database for handle */
index b106ff79dde9d361c1132f00d9abf6ea3c54fe52..78f47b1290f92d04a725330424ad0269e527907e 100644 (file)
@@ -25,6 +25,8 @@ RDEPEND="dev-libs/libltdl:0
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
+PATCHES=( "${FILESDIR}"/${PN}-1.0.17-mysql-8-my_bool.patch )
+
 MAKEOPTS="${MAKEOPTS} -j1" #500574, required for both src_compile() and src_install()
 
 src_prepare() {