dev-ros/visp_camera_calibration: eapi7
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 16:41:22 +0000 (18:41 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 16:54:36 +0000 (18:54 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/visp_camera_calibration/visp_camera_calibration-0.11.1.ebuild
dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild

index 37777151105ecb16786e4f0b8413d164c2b7262c..9ca3a9dedfc11e3460ac1fc375cfbe56521daba4 100644 (file)
@@ -1,13 +1,12 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/lagadic/vision_visp"
 KEYWORDS="~amd64 ~arm"
 VER_PREFIX="kinetic-"
 ROS_SUBDIR=${PN}
 CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
 
 inherit ros-catkin
@@ -19,13 +18,14 @@ IUSE=""
 
 RDEPEND="
        dev-ros/camera_calibration_parsers
-       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/roscpp
        dev-ros/visp_bridge
        sci-libs/ViSP:=
        dev-libs/boost:=
 "
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
 if [ "${PV#9999}" = "${PV}" ] ; then
        S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
 fi
index 37777151105ecb16786e4f0b8413d164c2b7262c..9ca3a9dedfc11e3460ac1fc375cfbe56521daba4 100644 (file)
@@ -1,13 +1,12 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/lagadic/vision_visp"
 KEYWORDS="~amd64 ~arm"
 VER_PREFIX="kinetic-"
 ROS_SUBDIR=${PN}
 CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
 
 inherit ros-catkin
@@ -19,13 +18,14 @@ IUSE=""
 
 RDEPEND="
        dev-ros/camera_calibration_parsers
-       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/roscpp
        dev-ros/visp_bridge
        sci-libs/ViSP:=
        dev-libs/boost:=
 "
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
 if [ "${PV#9999}" = "${PV}" ] ; then
        S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
 fi