games-rpg/asphyxia: New package
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 7 Jul 2019 20:11:31 +0000 (21:11 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 7 Jul 2019 20:11:31 +0000 (21:11 +0100)
Package-Manager: Portage-2.3.68, Repoman-2.3.13
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-rpg/asphyxia/Manifest [new file with mode: 0644]
games-rpg/asphyxia/asphyxia-1.0.ebuild [new file with mode: 0644]
games-rpg/asphyxia/metadata.xml [new file with mode: 0644]

diff --git a/games-rpg/asphyxia/Manifest b/games-rpg/asphyxia/Manifest
new file mode 100644 (file)
index 0000000..1f23fd2
--- /dev/null
@@ -0,0 +1 @@
+DIST Asphyxia-1.0-linux.tar 282880294 BLAKE2B cb27797413238c2e828232d46626889379ee8e9b10bc224812215e811927f50d640d520a3c399d3b58da12a5d6e6957020f89c70629c037f5334e8dca8706ba5 SHA512 9e28fe4b961a03b89b717589d7ba223374dfa12710a1f101b61c913a50dc750a6c2c8733d9b312001c92b6eeb58903028eec8e7a0b62de3f52f56eef6971e07e
diff --git a/games-rpg/asphyxia/asphyxia-1.0.ebuild b/games-rpg/asphyxia/asphyxia-1.0.ebuild
new file mode 100644 (file)
index 0000000..979aa1a
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Asphyxia"
+
+DESCRIPTION="Visual novel where the main character has one day to make peace with her friend"
+HOMEPAGE="https://ebihime.itch.io/${PN}"
+SRC_URI="${MY_PN}-${PV}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-linux"
+
+pkg_nofetch() {
+       einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+       einfo "it to your distfiles directory. If you have some other version then"
+       einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+       insinto /usr/share/${PN}
+       doins -r game/*
+
+       make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+       newicon -s 48 icon.png ${PN}.png
+       make_desktop_entry ${PN} "${MY_PN}"
+
+       docinto html
+       dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/asphyxia/metadata.xml b/games-rpg/asphyxia/metadata.xml
new file mode 100644 (file)
index 0000000..26079e6
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+</pkgmetadata>