dev-python/zope-testrunner: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:17:46 +0000 (14:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:20:16 +0000 (14:20 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/zope-testrunner/Manifest
dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild [deleted file]

index f412e799d3114a40bf6669e2a4124af7dcd02fd7..79445bfac6baf84a3c4bddf2e9bfb74ba7946fa2 100644 (file)
@@ -1,2 +1 @@
-DIST zope.testrunner-4.7.0.zip 260508 BLAKE2B 5ff63debf8119aff46a8c3ee72a4431815b37de80922cb5b8e4a318cb99200acf7dd6181b15a8233ed879f312997aab68a3439dab3dbc737093cde1ae48d619e SHA512 edda96e6871d954bb1f46ca18e2de9d1726d68cb3787f080b3b858c4dbdc2ceeb809962d178350a354e16c04711a89b2c6d1f663f256e1f72c15a7c494e51d32
 DIST zope.testrunner-5.1.tar.gz 140679 BLAKE2B 4044b9c77bbda6610b803fbc91cb7bb4d1aaeeb041c32cb91ecd05e05d75a685cd4b6d4531fdcb74380e6ce3fc40f32d21f71ad346491667458a165a90e3a401 SHA512 685d1e1512bd85a00c34f4f89ca1e0f8d1f0939de7b25db0cb43da44e5e41e735e1e9a5ccf2a89b959d7d5f074da71dfe0fd931bd62082159ec65c0b53cd38c1
diff --git a/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild b/dev-python/zope-testrunner/zope-testrunner-4.7.0.ebuild
deleted file mode 100644 (file)
index f3b9415..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope testrunner script"
-HOMEPAGE="https://pypi.org/project/zope.testrunner/ https://github.com/zopefoundation/zope.testrunner"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# TODO: extras?
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/zope-exceptions[${PYTHON_USEDEP}]
-       dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
-       # some tests rely on .pyc files being present
-       local -x PYTHONDONTWRITEBYTECODE=
-       esetup.py test
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       # remove .pth files since dev-python/namespace-zope handles the ns
-       find "${D}" -name '*.pth' -delete || die
-}