Use a separate if/then to group boolean or'd expressions together, rather
authorZac Medico <zmedico@gentoo.org>
Mon, 23 Mar 2009 00:57:29 +0000 (00:57 -0000)
committerZac Medico <zmedico@gentoo.org>
Mon, 23 Mar 2009 00:57:29 +0000 (00:57 -0000)
than a subshell.

svn path=/main/trunk/; revision=13149

bin/ebuild.sh

index f548a8f05c37a3fc94a82295808f42cd32807bbe..79db02cf3e966766b77ce576691b8b6fd9efc816 100755 (executable)
@@ -1862,12 +1862,11 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm depend && \
        unset PORTAGE_SANDBOX_ON
 fi
 
-if ! hasq "$EBUILD_PHASE" clean cleanrm && \
-       (
-               hasq ${EBUILD_PHASE} depend || \
-               [[ ! -f $T/environment || -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
-               hasq noauto ${FEATURES}
-       ) ; then
+if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
+if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
+       -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
+       hasq noauto $FEATURES ; then
+
        # The bashrcs get an opportunity here to set aliases that will be expanded
        # during sourcing of ebuilds and eclasses.
        source_all_bashrcs
@@ -1907,6 +1906,7 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm && \
        # This needs to be exported since prepstrip is a separate shell script.
        [[ -n $QA_PRESTRIPPED ]] && export QA_PRESTRIPPED
 fi
+fi
 
 # Set default EAPI if necessary, so that most
 # code can simply assume that it's defined.