net-libs/rb_libtorrent: 1.0.11 version bump, fix tests, ABI break
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 7 Mar 2017 21:12:31 +0000 (22:12 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 7 Mar 2017 22:14:32 +0000 (23:14 +0100)
Dropped eutils.eclass.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-libs/rb_libtorrent/Manifest
net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-fix-abicompat.patch [new file with mode: 0644]
net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-fix-test_ssl.patch [new file with mode: 0644]
net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-move-header.patch [new file with mode: 0644]
net-libs/rb_libtorrent/rb_libtorrent-1.0.11.ebuild [new file with mode: 0644]

index 9602799a65982c5ae4d46ca25851e45b85aecf49..522bf25c445fce0bd5ac070de4bc6bf3ed0a4570 100644 (file)
@@ -1,4 +1,5 @@
 DIST libtorrent-rasterbar-0.16.17.tar.gz 3018881 SHA256 67a1d29c626d991d6e39c2f9828ca70c4053d057070ce01fff9b4ad37e64aff0 SHA512 532b2438e24c3ecad239480a1bd6241a0d73d40f8d5bdcf61ddfcee1a41f1644c9004d4f234968efd50158224219b78852ec936a05b75b15f3442b594460cdd6 WHIRLPOOL 755e201741ed77cf91cb0976cbaa83c645647341d2cfe40564552599f2792ba76bd02e82a94669d80b199f1a1d6290824686d2bb52d6b0da8663d2274176f3eb
 DIST libtorrent-rasterbar-0.16.19.tar.gz 3030253 SHA256 9ebd3fa8accfa27d0c81cdbbe15d7b411ea1deec34ac6325dec7197f05d82982 SHA512 8e605802cb1ae80228d253adba44da6f5af39e7d65c59f65e15444ed1122500529ee068f6d3608b1c2a249f18b4de695073f7b67772fa445618757697d779340 WHIRLPOOL 4429d07bd95f398a09f283a7cbcf6611aeb8ac5d2b8ed76d98f89d601aa6ed66e6eb8f044b351fad6cca3606351ccc67081dba7c8dd8d9c3c433eae84aedeb2c
 DIST libtorrent-rasterbar-1.0.10.tar.gz 3324494 SHA256 a865ceaca8b14acdd7be56d361ce4e64361299647e157ef7b3ac7e2812ca4c3e SHA512 08976239ec12e2d67a974dadf3f16330f48e4b6de314f9d97c5fbbdbc696b76b6b1f8e20ceab6830d46d17b1bfd7e2fe4048fb1a5a97ece12c242c0cd0f7ded2 WHIRLPOOL 1e4ef2fb41eef0b825bd7c8c665638e3f689c3cefca3caa18a01c328caad9d31cd417fb49d25a7d55da6457a89e35a891427d70fb4f4d070c74be2e2e0347a60
+DIST libtorrent-rasterbar-1.0.11.tar.gz 3325786 SHA256 828d686770346f6da2c143c5a2844c5f5e407eb4a37982e90022763508abd62f SHA512 770d16b241174ae4b121af9b2ac7bcde8b14c6ed99352b827b760a3cbdc2c0ebd0d505319762897720c5f72acdff506ee9948ac1140e6d4591805eca5439b184 WHIRLPOOL e56bfe0830cfc7776436552171b14b08913d99a2c726c9eefa828027caaa96d9c3d97e6442a3b53f315eaa3e7e0f68175d813dbab1d6de1da5937054fc6cac9c
 DIST libtorrent-rasterbar-1.1.1.tar.gz 3641815 SHA256 f70c82367b0980460ef95aff3e117fd4a174477892d529beec434f74d615b31f SHA512 9d2409ee733f7579df61a63e37092d3c59a386b94031bae6a7ea64ffff617131d2c347ba0825b3d337ce2fedad3b527c8f697e3b49cea643d6543c972a1ebc12 WHIRLPOOL 36c4a007e0bf684e9603cd88b594a8ff91193b7d73447375e5651f945dba713c91daf0c625f90af6bb35c2ab017ca69da50d856ac6ce6be2e13f6d04ee7b2e35
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-fix-abicompat.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-fix-abicompat.patch
new file mode 100644 (file)
index 0000000..eebee12
--- /dev/null
@@ -0,0 +1,157 @@
+From 76381835be19da2f8f1fc501445e31d32e6d83e4 Mon Sep 17 00:00:00 2001
+From: Arvid Norberg <arvid.norberg@gmail.com>
+Date: Sun, 12 Feb 2017 21:05:22 -0500
+Subject: [PATCH] fix ABI compatibility issue introduced with preformatted
+ entry type (#1702)
+
+fix ABI compatibility issue introduced with preformatted entry type
+---
+ ChangeLog                              |  2 ++
+ bindings/python/src/create_torrent.cpp |  2 +-
+ include/libtorrent/create_torrent.hpp  |  6 ++++++
+ src/create_torrent.cpp                 | 31 ++++++++++++++++++++++++++++---
+ src/torrent.cpp                        | 11 ++++++++---
+ test/test_create_torrent.cpp           |  2 +-
+ 6 files changed, 46 insertions(+), 8 deletions(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index 9b501ce..9defe7c 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,5 @@
++      * fix ABI compatibility issue introduced with preformatted entry type
++
+ 1.0.11 release
+       * updating super seeding would include the torrent in state_update_alert
+diff --git a/bindings/python/src/create_torrent.cpp b/bindings/python/src/create_torrent.cpp
+index 55b6b51..31abb07 100644
+--- a/bindings/python/src/create_torrent.cpp
++++ b/bindings/python/src/create_torrent.cpp
+@@ -127,7 +127,7 @@ void bind_create_torrent()
+     class_<create_torrent>("create_torrent", no_init)
+         .def(init<file_storage&>())
+-        .def(init<torrent_info const&>(arg("ti")))
++        .def(init<torrent_info const&, int>((arg("ti"), arg("version") = LIBTORRENT_VERSION_NUM)))
+         .def(init<file_storage&, int, int, int>((arg("storage"), arg("piece_size") = 0
+             , arg("pad_file_limit") = -1, arg("flags") = int(libtorrent::create_torrent::optimize))))
+diff --git a/include/libtorrent/create_torrent.hpp b/include/libtorrent/create_torrent.hpp
+index 05dc6ca..d55e86a 100644
+--- a/include/libtorrent/create_torrent.hpp
++++ b/include/libtorrent/create_torrent.hpp
+@@ -42,6 +42,7 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include "libtorrent/utf8.hpp"
+ #include "libtorrent/allocator.hpp"
+ #include "libtorrent/file.hpp" // for combine_path etc.
++#include "libtorrent/version.hpp"
+ #include <vector>
+ #include <string>
+@@ -171,9 +172,12 @@ namespace libtorrent
+               // ``alignment`` is used when pad files are enabled. This is the size
+               // eligible files are aligned to. The default is -1, which means the
+               // piece size of the torrent.
++              // The ``use_preformatted`` parameter can be set to true to preserve
++              // invalid encoding of the .torrent file.
+               create_torrent(file_storage& fs, int piece_size = 0
+                       , int pad_file_limit = -1, int flags = optimize, int alignment = -1);
+               create_torrent(torrent_info const& ti);
++              create_torrent(torrent_info const& ti, bool use_preformatted);
+               // internal
+               ~create_torrent();
+@@ -290,6 +294,8 @@ namespace libtorrent
+       private:
++              void load_from_torrent_info(torrent_info const& ti, bool const use_preformatted);
++
+               file_storage& m_files;
+               // if m_info_dict is initialized, it is 
+               // used instead of m_files to generate
+diff --git a/src/create_torrent.cpp b/src/create_torrent.cpp
+index df4c759..aab5574 100644
+--- a/src/create_torrent.cpp
++++ b/src/create_torrent.cpp
+@@ -330,6 +330,24 @@ namespace libtorrent
+               , m_include_symlinks(false)
+               , m_calculate_file_hashes(false)
+       {
++              load_from_torrent_info(ti, false);
++      }
++
++      create_torrent::create_torrent(torrent_info const& ti, bool const use_preformatted)
++              : m_files(const_cast<file_storage&>(ti.files()))
++              , m_creation_date(time(0))
++              , m_multifile(ti.num_files() > 1)
++              , m_private(ti.priv())
++              , m_merkle_torrent(ti.is_merkle_torrent())
++              , m_include_mtime(false)
++              , m_include_symlinks(false)
++              , m_calculate_file_hashes(false)
++      {
++              load_from_torrent_info(ti, use_preformatted);
++      }
++
++      void create_torrent::load_from_torrent_info(torrent_info const& ti, bool const use_preformatted)
++      {
+               TORRENT_ASSERT(ti.is_valid());
+               if (!ti.is_valid()) return;
+@@ -361,9 +379,16 @@ namespace libtorrent
+               m_piece_hash.resize(m_files.num_pieces());
+               for (int i = 0; i < num_pieces(); ++i) set_hash(i, ti.hash_for_piece(i));
+-              boost::shared_array<char> const info = ti.metadata();
+-              int const size = ti.metadata_size();
+-              m_info_dict.preformatted().assign(&info[0], &info[0] + size);
++              if (use_preformatted)
++              {
++                      boost::shared_array<char> const info = ti.metadata();
++                      int const size = ti.metadata_size();
++                      m_info_dict.preformatted().assign(&info[0], &info[0] + size);
++              }
++              else
++              {
++                      m_info_dict = bdecode(&ti.metadata()[0], &ti.metadata()[0] + ti.metadata_size());
++              }
+               m_info_hash = ti.info_hash();
+       }
+diff --git a/src/torrent.cpp b/src/torrent.cpp
+index 75f0cc7..ef05dfd 100644
+--- a/src/torrent.cpp
++++ b/src/torrent.cpp
+@@ -5601,9 +5601,14 @@ namespace libtorrent
+               {
+                       if (m_magnet_link || (m_save_resume_flags & torrent_handle::save_info_dict))
+                       {
+-                              boost::shared_array<char> const info = torrent_file().metadata();
+-                              int const size = torrent_file().metadata_size();
+-                              ret["info"].preformatted().assign(&info[0], &info[0] + size);
++                              ret["info"] = bdecode(&torrent_file().metadata()[0]
++                                      , &torrent_file().metadata()[0] + torrent_file().metadata_size());
++// TODO: re-enable this code once there's a non-inlined encoder function. Or
++// perhaps this should not be used until saving resume_data via
++// add_torrent_params and a free function, similar to read_resume_data
++//                            boost::shared_array<char> const info = torrent_file().metadata();
++//                            int const size = torrent_file().metadata_size();
++//                            ret["info"].preformatted().assign(&info[0], &info[0] + size);
+                       }
+               }
+diff --git a/test/test_create_torrent.cpp b/test/test_create_torrent.cpp
+index 0a87c08..33fd3e8 100644
+--- a/test/test_create_torrent.cpp
++++ b/test/test_create_torrent.cpp
+@@ -51,7 +51,7 @@ int test_main()
+       lt::torrent_info info(test_torrent, sizeof(test_torrent) - 1);
+-      lt::create_torrent t(info);
++      lt::create_torrent t(info, true);
+       std::vector<char> buffer;
+       lt::bencode(std::back_inserter(buffer), t.generate());
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-fix-test_ssl.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-fix-test_ssl.patch
new file mode 100644 (file)
index 0000000..2add42c
--- /dev/null
@@ -0,0 +1,21 @@
+From 7f060e4a70b21974bcf154cf1a93c7b68c5a9aa8 Mon Sep 17 00:00:00 2001
+From: Alden Torres <aldenml@gmail.com>
+Date: Sat, 8 Oct 2016 01:12:15 -0400
+Subject: [PATCH] fix openssl compilation with boost 1.62 (#1193)
+
+---
+ test/test_ssl.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/test/test_ssl.cpp b/test/test_ssl.cpp
+index 659973c..5aa6b15 100644
+--- a/test/test_ssl.cpp
++++ b/test/test_ssl.cpp
+@@ -47,7 +47,6 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include <boost/asio/connect.hpp>
+ #ifdef TORRENT_USE_OPENSSL
+-#include <boost/asio/ssl/error.hpp> // for asio::error::get_ssl_category()
+ #include <boost/asio/ssl.hpp>
+ using namespace libtorrent;
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-move-header.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.11-move-header.patch
new file mode 100644 (file)
index 0000000..589998b
--- /dev/null
@@ -0,0 +1,34 @@
+From ecd20f15cb3fa5a0ebabd647b1f57f3cd62cb4b7 Mon Sep 17 00:00:00 2001
+From: sledgehammer_999 <hammered999@gmail.com>
+Date: Mon, 20 Feb 2017 01:22:27 +0200
+Subject: [PATCH] Move include into implementation instead(from #1702).
+
+---
+ bindings/python/src/create_torrent.cpp | 1 +
+ include/libtorrent/create_torrent.hpp  | 1 -
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bindings/python/src/create_torrent.cpp b/bindings/python/src/create_torrent.cpp
+index 31abb07..e856d85 100644
+--- a/bindings/python/src/create_torrent.cpp
++++ b/bindings/python/src/create_torrent.cpp
+@@ -6,6 +6,7 @@
+ #include <libtorrent/create_torrent.hpp>
+ #include <libtorrent/file_storage.hpp>
+ #include "libtorrent/intrusive_ptr_base.hpp"
++#include <libtorrent/version.hpp>
+ #include "bytes.hpp"
+ using namespace boost::python;
+diff --git a/include/libtorrent/create_torrent.hpp b/include/libtorrent/create_torrent.hpp
+index d55e86a..8d2c680 100644
+--- a/include/libtorrent/create_torrent.hpp
++++ b/include/libtorrent/create_torrent.hpp
+@@ -42,7 +42,6 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include "libtorrent/utf8.hpp"
+ #include "libtorrent/allocator.hpp"
+ #include "libtorrent/file.hpp" // for combine_path etc.
+-#include "libtorrent/version.hpp"
+ #include <vector>
+ #include <string>
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.11.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.11.ebuild
new file mode 100644 (file)
index 0000000..1bc5f65
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+DISTUTILS_IN_SOURCE_BUILD=true
+
+inherit distutils-r1 versionator
+
+MY_P=libtorrent-rasterbar-${PV} # TODO: rename, bug 576126
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +dht doc examples +geoip libressl python +ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+       dev-libs/boost:=[threads]
+       virtual/libiconv
+       geoip? ( dev-libs/geoip )
+       python? (
+               ${PYTHON_DEPS}
+               dev-libs/boost:=[python,${PYTHON_USEDEP}]
+       )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )
+"
+DEPEND="${COMMON_DEPEND}
+       sys-devel/libtool
+"
+RDEPEND="${COMMON_DEPEND}
+       examples? ( !net-p2p/mldonkey )
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.0.9-test_torrent_parse.patch"
+       # RC_1_0 branch
+       "${FILESDIR}/${P}-fix-abicompat.patch"
+       "${FILESDIR}/${P}-move-header.patch"
+       # master branch
+       "${FILESDIR}/${P}-fix-test_ssl.patch"
+)
+
+src_prepare() {
+       default
+
+       # bug 578026
+       # prepend -L${S}/... to ensure bindings link against the lib we just built
+       sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/compile_flags.in || die
+
+       use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable debug)
+               $(use_enable debug logging)
+               $(use_enable debug statistics)
+               $(use_enable debug disk-stats)
+               $(use_enable dht dht $(usex debug logging yes))
+               $(use_enable examples)
+               $(use_enable geoip)
+               $(use_with   geoip libgeoip)
+               $(use_enable ssl encryption)
+               $(use_enable static-libs static)
+               $(use_enable test tests)
+               --with-libiconv
+       )
+       econf "${myeconfargs[@]}"
+
+       if use python; then
+               myeconfargs+=(
+                       --enable-python-binding
+                       --with-boost-python
+               )
+               python_configure() {
+                       econf "${myeconfargs[@]}"
+               }
+               distutils-r1_src_configure
+       fi
+}
+
+src_compile() {
+       default
+
+       python_compile() {
+               cd "${BUILD_DIR}/../bindings/python" || die
+               distutils-r1_python_compile
+       }
+       use python && distutils-r1_src_compile
+}
+
+src_install() {
+       use doc && HTML_DOCS+=( "${S}"/docs )
+
+       default
+
+       python_install() {
+               cd "${BUILD_DIR}/../bindings/python" || die
+               distutils-r1_python_install
+       }
+       use python && distutils-r1_src_install
+
+       find "${D}" -name '*.la' -delete || die
+}