dev-python/kafka-python: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:50:15 +0000 (21:50 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:50:15 +0000 (21:50 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/kafka-python/Manifest
dev-python/kafka-python/kafka-python-1.3.3.ebuild [deleted file]

index d71dc6b04f5156969bbde5f9e5b2fc6343c9813c..1db6ff139ac4e25fc4140ea00181723495690814 100644 (file)
@@ -1,2 +1 @@
-DIST kafka-python-1.3.3.tar.gz 255686 BLAKE2B 01ce6d3faf55988f291a0aeb26f6e5e01407c02d440f21622e565a124595e2df46e253c539ef1ffe44405960249ba49f426f25a6a6ef3b67d3f3f1bf6fe37aee SHA512 19b43ddc7a1ad3fcf58c55198de60c4434bfa3747d5bbc40f1acf0aa28225eae87effbae69087919b111cb739010bd4087e2497fdc78987f4cdaf33e81e516b3
 DIST kafka-python-1.4.7.tar.gz 352844 BLAKE2B 812c185bf19f3398c358722a44feb572693556ec671d07f2d74d63e45473f5b6d35390cc0fa2c95b8c42a15b635237ffa3c3829adde1f60a7611ce4fdf06f587 SHA512 5bbf9f998fba12e8e7c67a48e82b04e745f1ac528684e91b7454e825656e4a68b8c369984308cff575241b7f808f52f16ab02b7effd6d6b4319215f44ae4748e
diff --git a/dev-python/kafka-python/kafka-python-1.3.3.ebuild b/dev-python/kafka-python/kafka-python-1.3.3.ebuild
deleted file mode 100644 (file)
index 4163d16..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Kafka protocol support in Python"
-HOMEPAGE="https://github.com/dpkp/kafka-python/ https://pypi.org/project/kafka-python/"
-SRC_URI="https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="snappy test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/unittest2[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       unit2 -v || die "tests failed with ${EPYTHON}"
-}