dev-python/matterhook: add py3.7, 3.8 fix #719094
authorAlexys Jacob <ultrabug@gentoo.org>
Sun, 10 May 2020 20:49:42 +0000 (22:49 +0200)
committerAlexys Jacob <ultrabug@gentoo.org>
Sun, 10 May 2020 20:50:24 +0000 (22:50 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
dev-python/matterhook/matterhook-0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/matterhook/matterhook-0.1-r1.ebuild b/dev-python/matterhook/matterhook-0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..0a9016c
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interact with Mattermost incoming webhooks easily"
+HOMEPAGE="https://github.com/numberly/matterhook"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"