media-sound/beets: Remove USE flac,ogg,opus; fix USE gstreamer
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Sep 2018 20:43:42 +0000 (22:43 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Sep 2018 21:06:41 +0000 (23:06 +0200)
They were effectively only used if USE +replaygain +gstreamer were enabled,
not ticking any build switches but purely forwarding USE dependencies.
Depend on media-plugins/gst-plugins-meta instead.

gstreamer is also being used if USE +mpd.

Reviewed-by: Mart Raudsepp <leio@gentoo.org>
Quote:
replaygain uses decodebin, thus should depend on
media-plugins/gst-plugins-meta:1.0 to pull in any decided by user decoders.
It uses rganalysis explicitly, for which it needs to depend on
media-libs/gst-plugins-good:1.0. Other explicitly used elements are all
from core or base, thus the gst-plugins-meta dep will cover it, or you can
be explicit (core = media-libs/gstreamer).

Additionally there is beetsplug/bpd/gstplayer.py that uses playbin. I don't
know what that thing is about, but it seems irrelevant to replaygain, so
might want a gstreamer? ( media-plugins/gst-plugins-meta:1.0 ) independent
of USE=replaygain, if it's optional enough to work fine without it
installed without losing anything important.

Package-Manager: Portage-2.3.49, Repoman-2.3.10

media-sound/beets/beets-1.4.7.ebuild

index 7a21e504abd5b647eb08e181b68471730ae6265d..b0ea1935a00a511336de7adbb2273486cd7ecbcf 100644 (file)
@@ -17,7 +17,7 @@ HOMEPAGE="http://beets.io/ https://pypi.org/project/beets/"
 KEYWORDS="~amd64 ~x86"
 SLOT="0"
 LICENSE="MIT"
-IUSE="badfiles chromaprint doc discogs ffmpeg flac gstreamer lastfm mpd ogg opus replaygain test thumbnail webserver"
+IUSE="badfiles chromaprint doc discogs ffmpeg gstreamer lastfm mpd replaygain test thumbnail webserver"
 
 RDEPEND="
        dev-python/jellyfish[${PYTHON_USEDEP}]
@@ -45,15 +45,13 @@ RDEPEND="
        mpd? (
                dev-python/bluelet[${PYTHON_USEDEP}]
                dev-python/python-mpd[${PYTHON_USEDEP}]
+               gstreamer? ( media-plugins/gst-plugins-meta:1.0 )
        )
        replaygain? (
                gstreamer? (
                        dev-python/pygobject:3[${PYTHON_USEDEP}]
-                       media-libs/gstreamer:1.0[introspection]
-                       media-libs/gst-plugins-base:1.0[ogg?]
                        media-libs/gst-plugins-good:1.0
-                       flac? ( media-plugins/gst-plugins-flac:1.0 )
-                       opus? ( media-plugins/gst-plugins-opus:1.0 )
+                       media-plugins/gst-plugins-meta:1.0
                )
                !gstreamer? ( media-sound/mp3gain )
        )