dev-python/rosdistro: bump to 0.8.1
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 14:27:48 +0000 (16:27 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 15:18:15 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-python/rosdistro/Manifest
dev-python/rosdistro/rosdistro-0.8.1.ebuild [new file with mode: 0644]
dev-python/rosdistro/rosdistro-9999.ebuild

index c988199233fc73bb4e2318a2eec6cac510573ba6..cc49f4a4757e31f416ee3cae8aa425232ae51bbe 100644 (file)
@@ -1 +1,2 @@
 DIST rosdistro-0.8.0.tar.gz 60527 BLAKE2B 9404452dc62c9f7d1482de3c13df0093ac26a60554c97fa097cb14548cdb814fbdc96a26db2d24aa1f2eb99de86f27807ecdc50e0e00a8fa727af8803ab5d644 SHA512 1f4620454f78bd03f75a8b1b8535588a8d6e50aeef17dbf346e8d0443a6fbc5ec83646767bf86521fb65508e205fc3edb8f0c97a81aec8d6b72088d9d78a14f0
+DIST rosdistro-0.8.1.tar.gz 61268 BLAKE2B 16de2f747eab59f0d2eb880cfa5cde8b62f8f6b71773f1c72665c5b58bf9f63f8e593b2dd0924b104488ce5e7e5bdf930a52db677180542806a899970ede5b37 SHA512 3d49aaf460904e2cce635443cb95ca54bdd429549016a614da7038703752187a00b98916e2826193897048753a2b2727eb153296d30abe66c56bd54d68648b08
diff --git a/dev-python/rosdistro/rosdistro-0.8.1.ebuild b/dev-python/rosdistro/rosdistro-0.8.1.ebuild
new file mode 100644 (file)
index 0000000..d2cbf76
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+"
+PATCHES=( "${FILESDIR}/yaml.patch" )
+
+src_prepare() {
+       # Requires network access
+       rm -f test/test_manifest_providers.py
+       default
+}
+
+python_test() {
+       nosetests --with-xunit test || die
+}
index 7455f6d0af0c9d68483f99d02a2022a736a30f69..d2cbf7643d5ceb695d17d374af5c7ae05bde8661 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
+PYTHON_COMPAT=( python{3_6,3_7} )
 
 SCM=""
 if [ "${PV#9999}" != "${PV}" ] ; then