sci-mathematics/z3: Bump to 4.8.8
authorMichał Górny <mgorny@gentoo.org>
Thu, 14 May 2020 06:17:44 +0000 (08:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 14 May 2020 06:17:44 +0000 (08:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-mathematics/z3/Manifest
sci-mathematics/z3/z3-4.8.8.ebuild [new file with mode: 0644]

index 479dc2277d148fc9508ed185d7504e8d6b51e9ef..4957c984b18a40aadd650f23137910c7166249ee 100644 (file)
@@ -1 +1,2 @@
 DIST z3-4.8.6.tar.gz 4328752 BLAKE2B 4932670f3c1ab9bdba18a6ad80f4fd8812eb70d71705ebdf1f93c3b052ffb632dc10e4f7f4043f098af214288d6d4a4a26ef7f8cc0d1183c9f27b14ef1787c46 SHA512 d338413274a3d11a9e9287202989df9da4c31e095c14428a418d4019e9f86c0e2b681c519d2d0bcbb4cd99a722a2539006f5c86ade568b1ee208545b142369f1
+DIST z3-4.8.8.tar.gz 4520119 BLAKE2B 8d3d9fac61ac7d5a9d8c44323db9f67a7b24ee510b12e67867b249062cbcfe9a3bd0fa3b24c03c9eccd2aaf90451083ff5e9a9253a87c3e8e943fc5cf08a1893 SHA512 a6823cadb7cdad11b8f0db1530676c0ec4853886dfb3c4dbc5b798c5dbd445afb0c61675f81cb7f99c1b1734d9cd0ec96a07c68a948da3c25801fc6767fea47f
diff --git a/sci-mathematics/z3/z3-4.8.8.ebuild b/sci-mathematics/z3/z3-4.8.8.ebuild
new file mode 100644 (file)
index 0000000..949c33e
--- /dev/null
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       gmp? ( dev-libs/gmp:0=[cxx,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+       doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+               -DZ3_USE_LIB_GMP=$(usex gmp)
+               -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+               -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+               -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+               -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+               -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+               -DZ3_INCLUDE_GIT_HASH=OFF
+       )
+
+       cmake-utils_src_configure
+}
+
+multilib_src_test() {
+       cmake-utils_src_make test-z3
+       set -- "${BUILD_DIR}"/test-z3 /a
+       echo "${@}" >&2
+       "${@}" || die
+}
+
+multilib_src_install_all() {
+       dodoc README.md RELEASE_NOTES
+       use examples && dodoc -r examples
+       use python && python_optimize
+
+       if use isabelle; then
+               insinto /usr/share/Isabelle/contrib/${P}/etc
+               newins - settings <<-EOF
+                       Z3_COMPONENT="\$COMPONENT"
+                       Z3_HOME="${EPREFIX}/usr/bin"
+                       Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+                       Z3_REMOTE_SOLVER="z3"
+                       Z3_VERSION="${PV}"
+                       Z3_INSTALLED="yes"
+                       Z3_NON_COMMERCIAL="yes"
+               EOF
+       fi
+}
+
+pkg_postinst() {
+       if use isabelle; then
+               if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+                       sed -e "/contrib\/${PN}-[0-9.]*/d" \
+                               -i "${ROOT}/etc/isabelle/components" || die
+                       cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+                               contrib/${P}
+                       EOF
+               fi
+       fi
+}
+
+pkg_postrm() {
+       if use isabelle; then
+               if [[ ! ${REPLACING_VERSIONS} ]]; then
+                       if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+                               # Note: this sed should only match the version of this ebuild
+                               # Which is what we want as we do not want to remove the line
+                               # of a new Isabelle component being installed during an upgrade.
+                               sed -e "/contrib\/${P}/d" \
+                                       -i "${ROOT}/etc/isabelle/components" || die
+                       fi
+               fi
+       fi
+}