net-libs/nodejs: replace wrongly used subshell with 'if'
authorStefan Strogin <steils@gentoo.org>
Wed, 26 Feb 2020 00:35:59 +0000 (02:35 +0200)
committerStefan Strogin <steils@gentoo.org>
Wed, 26 Feb 2020 00:37:50 +0000 (02:37 +0200)
Closes: https://bugs.gentoo.org/710784
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Stefan Strogin <steils@gentoo.org>
net-libs/nodejs/nodejs-10.19.0.ebuild
net-libs/nodejs/nodejs-12.16.1.ebuild
net-libs/nodejs/nodejs-13.9.0.ebuild
net-libs/nodejs/nodejs-99999999.ebuild

index db37b4f351895da4baf0541d35a988241ba9ccdd..1aedca2b28c8529a85497af5846a3a10a46c5448 100644 (file)
@@ -100,7 +100,11 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot && myconf+=( --with-snapshot )
-       use ssl && ( use system-ssl && myconf+=( --shared-openssl ) ) || myconf+=( --without-ssl )
+       if use ssl; then
+               use system-ssl && myconf+=( --shared-openssl )
+       else
+               myconf+=( --without-ssl )
+       fi
 
        local myarch=""
        case ${ABI} in
index 6c929f7027868df679703e1a00a1af4b1506de9a..d0e7e0c5b4cf69fc6b85a1419d28a733e7f865b5 100644 (file)
@@ -107,7 +107,11 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot || myconf+=( --without-node-snapshot )
-       use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+       if use ssl; then
+               use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+       else
+               myconf+=( --without-ssl )
+       fi
 
        local myarch=""
        case ${ABI} in
index 4d35b0880936f8e0dc82097e975dea5fe4c4b16b..00513e8978c40f7de7e316c627e23a915bcf9237 100644 (file)
@@ -105,7 +105,11 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot || myconf+=( --without-node-snapshot )
-       use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+       if use ssl; then
+               use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+       else
+               myconf+=( --without-ssl )
+       fi
 
        local myarch=""
        case ${ABI} in
index 71618f3c5232651303f71395fcddd0aa6ed0b961..7a8dc689fddd1c2012866cda4457fcae7a2944b9 100644 (file)
@@ -102,7 +102,11 @@ src_configure() {
        use inspector || myconf+=( --without-inspector )
        use npm || myconf+=( --without-npm )
        use snapshot || myconf+=( --without-node-snapshot )
-       use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
+       if use ssl; then
+               use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+       else
+               myconf+=( --without-ssl )
+       fi
 
        local myarch=""
        case ${ABI} in