dev-perl/Festival-Client-Async: EAPI6 + Tests
authorKent Fredric <kentnl@gentoo.org>
Sat, 21 Oct 2017 08:09:00 +0000 (21:09 +1300)
committerKent Fredric <kentnl@gentoo.org>
Sat, 21 Oct 2017 08:38:00 +0000 (21:38 +1300)
- EAPI6
- Basic compile tests
- Document advanced testing

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild b/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild
new file mode 100644 (file)
index 0000000..6427667
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DJHD
+DIST_VERSION=0.0303
+inherit perl-module
+
+DESCRIPTION="Non-blocking interface to a Festival server"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+src_test() {
+       local MODULES=(
+               "Festival::Client::Async ${DIST_VERSION}"
+       )
+       local failed=()
+       for dep in "${MODULES[@]}"; do
+               ebegin "Compile testing ${dep}"
+                       perl -Mblib="${S}" -M"${dep} ()" -e1
+               eend $? || failed+=( "$dep" )
+       done
+       if [[ ${failed[@]} ]]; then
+               echo
+               eerror "One or more modules failed compile:";
+               for dep in "${failed[@]}"; do
+                       eerror "  ${dep}"
+               done
+               die "Failing due to module compilation errors";
+       fi
+       ewarn "Comprehensive testing may require manual steps. For details, see:"
+       ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Festival-Client-Async"
+       perl-module_src_test
+}