app-emacs/yaml-mode: add 0.0.13, update auto-mode-alist accordingly
authorHans de Graaff <graaff@gentoo.org>
Wed, 3 May 2017 08:55:02 +0000 (10:55 +0200)
committerHans de Graaff <graaff@gentoo.org>
Wed, 3 May 2017 18:25:59 +0000 (20:25 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.1

app-emacs/yaml-mode/Manifest
app-emacs/yaml-mode/files/50yaml-mode-gentoo.el
app-emacs/yaml-mode/yaml-mode-0.0.13.ebuild [new file with mode: 0644]

index 31c8b3e9c5db6c7fd37ead82de6b53848100e208..b062458d7aa9bb46f796b56c7948295b07f39b68 100644 (file)
@@ -1 +1,2 @@
+DIST yaml-mode-0.0.13.tar.gz 14446 SHA256 c547b1ec62e6b39fd3e95e28b8d3918958d4f00391c471485532dbc6cc3dcab8 SHA512 10876dfe576045bde363f62880ab3c91894d965c9dc1b7ff2b86783d31c05ab844c0abd77bcb1f7b5346d99969d69833ff4e5dc1b5700f7856fbd3dc4eebd5ef WHIRLPOOL 03300816f056fbe3d3e590c0f81a3593370b53f5c49aefb166bdbcca6823ffe4e4dae61dd4a0f091bff56f86cd33f07c8e2443dae3ba12910e1dc6b82169369b
 DIST yaml-mode-0.0.9.tar.gz 6498 SHA256 5d65852d9d738fd1966125f8ae737760ae48e647030e1aa5a78fd703f54358fc SHA512 cdfb0694d2efe5bb86ab5280e78d577d5bdac906a7745c6e988128cbb001f1f78569199288e2c12e7977a35c35f9e47f3271747bf26fcdfab5d2a961295550ea WHIRLPOOL 58ee875ce20ab49595b4372a979417deb672c09647f5b0859d3dddf484302b8bf4b65243e18709d7d6edec757d6528a59814f4b9f56fe98178d4966fcba5018f
index d535ff479b811bdee148f5e7bcc4d14774588dd8..7f6db15560f40bb38c35edccf99cd700d3150bf6 100644 (file)
@@ -1,3 +1,3 @@
 (add-to-list 'load-path "@SITELISP@")
 (autoload 'yaml-mode "yaml-mode" "Simple mode to edit YAML." t)
-(add-to-list 'auto-mode-alist '("\\.yml\\'" . yaml-mode))
+(add-to-list 'auto-mode-alist '("\\.\\(e?ya?\\|ra\\)ml\\'" . yaml-mode))
diff --git a/app-emacs/yaml-mode/yaml-mode-0.0.13.ebuild b/app-emacs/yaml-mode/yaml-mode-0.0.13.ebuild
new file mode 100644 (file)
index 0000000..36ae75d
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="A major mode for GNU Emacs for editing YAML files"
+HOMEPAGE="https://github.com/yoshiki/yaml-mode"
+SRC_URI="https://github.com/yoshiki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+#S="${WORKDIR}/${PN}-release-${PV}"
+DOCS="README Changes"
+SITEFILE="50${PN}-gentoo.el"