dev-python/futurist: adding for liberty
authorMatthew Thode <mthode@mthode.org>
Thu, 3 Sep 2015 21:24:23 +0000 (16:24 -0500)
committerMatthew Thode <mthode@mthode.org>
Thu, 3 Sep 2015 21:28:46 +0000 (16:28 -0500)
dev-python/futurist/Manifest [new file with mode: 0644]
dev-python/futurist/futurist-0.4.0.ebuild [new file with mode: 0644]
dev-python/futurist/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/futurist/Manifest b/dev-python/futurist/Manifest
new file mode 100644 (file)
index 0000000..7b9e62a
--- /dev/null
@@ -0,0 +1 @@
+DIST futurist-0.4.0.tar.gz 27870 SHA256 a0c97c7dc7bd8fa1abe0012c129a303ba652074709bfed6c71730bbfce6f18bf SHA512 0ff6be28a5ce45458e9af4957ce17f55fbe2eb5971d365fe23b3e58486b702167fb9f0d2709d86c4eb3cbc92693e6a4de9ca7b858c5be083180c5bb34e331e6a WHIRLPOOL 6b1694bd839c1c43602de50f3a2557f5ed3b16c9cc0c7b0a40a8a09b247e8df3ac486ff67e62ccf0de80ef1934e6925d38c34f6c7b0c46050d94f25b2078e6a5
diff --git a/dev-python/futurist/futurist-0.4.0.ebuild b/dev-python/futurist/futurist-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..8a9f1b0
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future."
+HOMEPAGE="https://pypi.python.org/pypi/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+       >=dev-python/pbr-1.4[${PYTHON_USEDEP}]
+       <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/monotonic-0.3[${PYTHON_USEDEP}]
+       virtual/python-futures[${PYTHON_USEDEP}]
+       >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/futurist/metadata.xml b/dev-python/futurist/metadata.xml
new file mode 100644 (file)
index 0000000..d5dfd32
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+</pkgmetadata>