adding 0.1.2 to the tree, thanks to pierre for the help in tracking something down
authorJoshua Jackson <tsunam@gentoo.org>
Wed, 15 Nov 2006 04:03:06 +0000 (04:03 +0000)
committerJoshua Jackson <tsunam@gentoo.org>
Wed, 15 Nov 2006 04:03:06 +0000 (04:03 +0000)
Package-Manager: portage-2.1.1-r1

x11-plugins/beryl-dbus/ChangeLog
x11-plugins/beryl-dbus/beryl-dbus-0.1.2.ebuild [new file with mode: 0644]
x11-plugins/beryl-dbus/files/digest-beryl-dbus-0.1.2 [new file with mode: 0644]
x11-plugins/beryl-plugins/ChangeLog
x11-plugins/beryl-plugins/beryl-plugins-0.1.2.ebuild [new file with mode: 0644]
x11-plugins/beryl-plugins/files/digest-beryl-plugins-0.1.2 [new file with mode: 0644]

index c3ff50dabf018cdc955ca0a77e4a3527e21275b6..4d67ca3a8970c8000b2ba2ead1a0d304598c1952 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for x11-plugins/beryl-dbus
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/beryl-dbus/ChangeLog,v 1.3 2006/10/28 20:27:10 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/beryl-dbus/ChangeLog,v 1.4 2006/11/15 04:01:30 tsunam Exp $
+
+*beryl-dbus-0.1.2 (15 Nov 2006)
+
+  15 Nov 2006; Joshua Jackson <tsunam@gentoo.org> +beryl-dbus-0.1.2.ebuild:
+  adding 0.1.2 to the tree
 
 *beryl-dbus-0.1.1-r1 (28 Oct 2006)
 
diff --git a/x11-plugins/beryl-dbus/beryl-dbus-0.1.2.ebuild b/x11-plugins/beryl-dbus/beryl-dbus-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..80880e5
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/beryl-dbus/beryl-dbus-0.1.2.ebuild,v 1.1 2006/11/15 04:01:30 tsunam Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Beryl Window Decorator Dbus Plugin"
+HOMEPAGE="http://beryl-project.org"
+SRC_URI="http://releases.beryl-project.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=x11-plugins/beryl-plugins-0.1.2
+       sys-apps/dbus"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_compile() {
+       filter-ldflags -znow -z,now -Wl,-znow -Wl,-z,now
+       glib-gettextize --copy --force || die
+
+       econf || die "econf failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/x11-plugins/beryl-dbus/files/digest-beryl-dbus-0.1.2 b/x11-plugins/beryl-dbus/files/digest-beryl-dbus-0.1.2
new file mode 100644 (file)
index 0000000..9eb0adb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 15e9d90594b8e9ffa59e41f5c766749f beryl-dbus-0.1.2.tar.bz2 225542
+RMD160 b4006e0ec0ef74434981572e8fed3130237373be beryl-dbus-0.1.2.tar.bz2 225542
+SHA256 ee53e7b343c15dc7d0ba23e7ff49ef551e774352ae8863d693acf5beeea69863 beryl-dbus-0.1.2.tar.bz2 225542
index f09c3796fdfec5e7dbe61fec78c50dce6e8f060e..a1a4149cbfd1e8c8f5930f456489516e01836838 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-plugins/beryl-plugins
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/beryl-plugins/ChangeLog,v 1.3 2006/10/28 20:24:25 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/beryl-plugins/ChangeLog,v 1.4 2006/11/15 04:03:06 tsunam Exp $
+
+*beryl-plugins-0.1.2 (15 Nov 2006)
+
+  15 Nov 2006; Joshua Jackson <tsunam@gentoo.org>
+  +beryl-plugins-0.1.2.ebuild:
+  adding 0.1.2 to the tree
 
 *beryl-plugins-0.1.1-r1 (28 Oct 2006)
 
diff --git a/x11-plugins/beryl-plugins/beryl-plugins-0.1.2.ebuild b/x11-plugins/beryl-plugins/beryl-plugins-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..e1d46a0
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/beryl-plugins/beryl-plugins-0.1.2.ebuild,v 1.1 2006/11/15 04:03:06 tsunam Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Beryl Window Decorator Plugins"
+HOMEPAGE="http://beryl-project.org"
+SRC_URI="http://releases.beryl-project.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="dbus"
+
+DEPEND="=x11-wm/beryl-core-0.1.2
+       >=gnome-base/librsvg-2.14.0"
+
+PDEPEND="dbus? ( =x11-plugins/beryl-dbus-0.1.2 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_compile() {
+       #filter ldflags to follow upstream
+       filter-ldflags -znow -z,now -Wl,-znow -Wl,-z,now
+       glib-gettextize --copy --force || die
+
+       econf || die "econf failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/x11-plugins/beryl-plugins/files/digest-beryl-plugins-0.1.2 b/x11-plugins/beryl-plugins/files/digest-beryl-plugins-0.1.2
new file mode 100644 (file)
index 0000000..b26597c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6721bf8bd5fcbe0cabb0a67caa920fcb beryl-plugins-0.1.2.tar.bz2 1849712
+RMD160 b3abeaecb580bbed9572e7e41fe65b81170bacd6 beryl-plugins-0.1.2.tar.bz2 1849712
+SHA256 f646a5976887c9d29e42f8dfb15daa3dd4bf20666a30834a37ad230270dfc703 beryl-plugins-0.1.2.tar.bz2 1849712