dev-python/markdown: Fix USE=doc
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Wed, 22 Jan 2020 09:58:56 +0000 (10:58 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 24 Jan 2020 06:54:32 +0000 (08:54 +0200)
Add py3_{7,8}

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Closes: https://github.com/gentoo/gentoo/pull/14345
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/markdown/markdown-3.1.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/markdown/markdown-3.1.1-r1.ebuild b/dev-python/markdown/markdown-3.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..2f068d7
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+       https://python-markdown.github.io/
+       https://pypi.org/project/Markdown/
+       https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="test? (
+       dev-python/pygments[${PYTHON_USEDEP}]
+       dev-python/pytidylib[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+       use doc && dodoc -r docs/
+
+       distutils-r1_python_install_all
+}