sci-chemistry/gnome-chemistry-utils: Introduce gnome chemistry utils
authorPacho Ramos <pacho@gentoo.org>
Sun, 1 Mar 2020 16:20:23 +0000 (17:20 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 1 Mar 2020 16:21:16 +0000 (17:21 +0100)
Closes: https://bugs.gentoo.org/388887
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
sci-chemistry/gnome-chemistry-utils/Manifest [new file with mode: 0644]
sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch [new file with mode: 0644]
sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.17.ebuild [new file with mode: 0644]
sci-chemistry/gnome-chemistry-utils/metadata.xml [new file with mode: 0644]

diff --git a/sci-chemistry/gnome-chemistry-utils/Manifest b/sci-chemistry/gnome-chemistry-utils/Manifest
new file mode 100644 (file)
index 0000000..2617843
--- /dev/null
@@ -0,0 +1 @@
+DIST gnome-chemistry-utils-0.14.17.tar.xz 5911248 BLAKE2B 5d3bb4afbe3d3f620912e810717f08674d56a11c384b1fb239788cfbbb625797e8c52de2b6d940ae7f3d83847533afedd6ed961b1fa0ea1cec62dda88de1a6df SHA512 01bb964e1484e028c5965f1de74798422b448823047fcadf668dc76e98b3e214939a2f031d0182c717c4376f490e5969a4604ee66d1763e6b480032d7ae97468
diff --git a/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch b/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch
new file mode 100644 (file)
index 0000000..826d9b0
--- /dev/null
@@ -0,0 +1,47 @@
+Index: gchemutils/configure.ac
+===================================================================
+--- gchemutils/configure.ac    (revision 2072)
++++ gchemutils/configure.ac    (revision 2073)
+@@ -352,7 +352,7 @@
+   libspreadsheet=libspreadsheet-1.12
+ fi
+-PKG_CHECK_MODULES(gnumeric, [$libspreadsheet >= 1.11.6], [build_gnumeric_plugin=yes],
++PKG_CHECK_MODULES(gnumeric, [$libspreadsheet >= 1.12.42], [build_gnumeric_plugin=yes],
+               [build_gnumeric_plugin=no])
+ dnl --without is not handled
+Index: gchemutils/gnumeric/functions.cc
+===================================================================
+--- gchemutils/gnumeric/functions.cc   (revision 2072)
++++ gchemutils/gnumeric/functions.cc   (revision 2073)
+@@ -195,23 +195,23 @@
+ const GnmFuncDescriptor Chemistry_functions[] = {
+         { N_("molarmass"),       "s",
+-                      help_molarmass, gnumeric_molarmass, NULL, NULL, NULL,
++                      help_molarmass, gnumeric_molarmass, NULL,
+                       GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+         { N_("monoisotopicmass"),       "s",
+-                      help_monoisotopicmass, gnumeric_monoisotopicmass, NULL, NULL, NULL,
++                      help_monoisotopicmass, gnumeric_monoisotopicmass, NULL,
+                       GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+         { N_("chemcomposition"),       "ss",
+-                      help_chemcomposition, gnumeric_chemcomposition, NULL, NULL, NULL,
++                      help_chemcomposition, gnumeric_chemcomposition, NULL,
+                       GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+         { N_("elementnumber"),       "s",
+-                      help_elementnumber, gnumeric_elementnumber, NULL, NULL, NULL,
++                      help_elementnumber, gnumeric_elementnumber, NULL,
+                       GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+         { N_("elementsymbol"),       "f",
+-                      help_elementsymbol, gnumeric_elementsymbol, NULL, NULL, NULL,
++                      help_elementsymbol, gnumeric_elementsymbol, NULL,
+                       GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+-        {NULL, NULL, NULL, NULL, NULL, NULL, NULL,
++        {NULL, NULL, NULL, NULL, NULL,
+                       GNM_FUNC_IS_PLACEHOLDER,  GNM_FUNC_IMPL_STATUS_UNIMPLEMENTED, GNM_FUNC_TEST_STATUS_NO_TESTSUITE}
+ };
diff --git a/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.17.ebuild b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.17.ebuild
new file mode 100644 (file)
index 0000000..a4cf565
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg
+
+DESCRIPTION="Programs and library containing GTK widgets and C++ classes related to chemistry"
+HOMEPAGE="http://gchemutils.nongnu.org/"
+SRC_URI="http://download.savannah.gnu.org/releases/gchemutils/$(ver_cut 1-2)/${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+IUSE="gnumeric"
+
+RDEPEND="
+       >=app-text/gnome-doc-utils-0.3.2
+       >=dev-libs/glib-2.36.0:2
+       >=dev-libs/libxml2-2.4.16:2
+       >=gnome-extra/libgsf-1.14.9
+       >=sci-chemistry/bodr-5
+       >=sci-chemistry/chemical-mime-data-0.1.94
+       >=sci-chemistry/openbabel-2.3.0:0
+       >=x11-libs/cairo-1.6.0
+       >=x11-libs/gdk-pixbuf-2.22.0
+       >=x11-libs/goffice-0.10.12
+       x11-libs/gtk+:3
+       >=x11-libs/libX11-1.0.0
+       gnumeric? ( >=app-office/gnumeric-1.12.42 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+       app-doc/doxygen
+"
+
+src_prepare() {
+       xdg_src_prepare
+
+       # From Debian
+       eapply "${FILESDIR}/${P}-gnumeric.patch"
+       eautoreconf
+}
+
+src_configure() {
+       # lasem is not in the tree
+       econf \
+               --without-lasem \
+               --disable-mozilla-plugin \
+               --disable-scrollkeeper \
+               --disable-update-databases
+}
+
+src_install() {
+       default
+
+       mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+       rm -rf "${ED}"/usr/share/mimelnk/ || die
+
+       find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/sci-chemistry/gnome-chemistry-utils/metadata.xml b/sci-chemistry/gnome-chemistry-utils/metadata.xml
new file mode 100644 (file)
index 0000000..0d27f61
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>pacho@gentoo.org</email>
+       </maintainer>
+       <use>
+               <flag name="gnumeric">Add a Gnumeric plugin to provide a molarmass function for the spreadsheet</flag>
+       </use>
+</pkgmetadata>