dev-ruby/puppetdb-termini: 6.10.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 2 May 2020 18:05:45 +0000 (13:05 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 2 May 2020 18:18:08 +0000 (13:18 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-ruby/puppetdb-termini/Manifest
dev-ruby/puppetdb-termini/puppetdb-termini-6.10.0.ebuild [new file with mode: 0644]

index af844a061352673acf1980a4058adcdd876bd455..e7d5308a961e10396372cb04da175fbda508562b 100644 (file)
@@ -1 +1,2 @@
+DIST puppetdb-termini_6.10.0-1stretch_all.deb 21294 BLAKE2B dfe88c6a44eed3e8a0826fde8f6130d3d817acafa367415956587e44298c99c41fd7bdac709c1ab55dcc9dce165d2599a2f18f0e1fd058d717128c0dd3a6ae28 SHA512 da7bf41e43acc39a44655e4759a14c119e6c1665c01a8b0ad4d83767c65068e071fc8ff6af80810a20cf92508c55c9ccfa295e197c0f7c94ee70110ea4515aae
 DIST puppetdb-termini_6.9.1-1stretch_all.deb 21294 BLAKE2B 579181f4404e5b9dfbc444364c58402135ea68bef0fd3bff894976ee04f7d181699d2456d5ee6105707b765ee1842fac38af7e97f07621436164d79ff8c32a35 SHA512 62d3ac5b922eb3b3ba50f47a104dfb04ca8f3284b2474ed45cf609b21696fa01fa2eaecaa1c94d7b50ac22e8b187b4efc8e43d3cb7d66bf02554b1c03996b040
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.10.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.10.0.ebuild
new file mode 100644 (file)
index 0000000..a7f2b53
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+       insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+       doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}