dev-python/pretend: Enable testing
authorMichał Górny <mgorny@gentoo.org>
Wed, 21 Feb 2018 19:42:14 +0000 (20:42 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 21 Feb 2018 19:43:23 +0000 (20:43 +0100)
dev-python/pretend/Manifest
dev-python/pretend/pretend-1.0.8-r1.ebuild [new file with mode: 0644]

index 0968c134b6fdf2ac8b6fb749cb790b86cb874e7f..236cfd5091950e2fef5d82b2978d364fc3ee7ded 100644 (file)
@@ -1 +1,2 @@
+DIST pretend-1.0.8.gh.tar.gz 5509 BLAKE2B 574c83f05c9b45876891df97a23a25cefb0f27f9ba76aa6d01fe8d2246f7b4457fb99522540d85108056dd83e79ed7179c4661d30fbc786ce2adf0c477a23560 SHA512 f0a3263f55afc43bfd63a6ba0ae876f2607ed9cc26352a3ec69933ebb79418a128c5c29c3e77a924b158da658d8ff2043a7f8e6d4ee3e499df22e4083329cf62
 DIST pretend-1.0.8.tar.gz 4848 BLAKE2B 396fae55208e39eadceaff92890b48d63b79a24e0d313a3b87d69b8a61655cb8a1a2f8823f06779e0730fb3505cb269ca907dd28a79fdd283ebd6913bd9c0ab3 SHA512 25011216947289d340fb979ebc9e2c7f000571f006cf5ce15f10ff0e013164e4329a3a66933d202acf8ced498929cf9e5a2a3666aafa00f78348400615c5cec8
diff --git a/dev-python/pretend/pretend-1.0.8-r1.ebuild b/dev-python/pretend/pretend-1.0.8-r1.ebuild
new file mode 100644 (file)
index 0000000..89d768e
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for stubbing in Python"
+HOMEPAGE="https://github.com/alex/pretend/ https://pypi.python.org/pypi/pretend/"
+SRC_URI="https://github.com/alex/pretend/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+       py.test -v || die
+}