Remove old version
authorTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 20:34:16 +0000 (20:34 +0000)
committerTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 20:34:16 +0000 (20:34 +0000)
Package-Manager: portage-2.1.2_rc2-r1

games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild

index 1e09aae94272b0d2f559df84d0e0e34fa6da474b..72530bd1a62cf3608f2cc61ecb447457c4440a21 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.5 2004/06/24 22:15:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.6 2006/11/23 20:34:16 nyhm Exp $
 
 inherit eutils games
 
@@ -10,21 +10,21 @@ SRC_URI="http://www.autismuk.freeserve.co.uk/yar-${PV}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="x86 sparc ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc sparc x86"
 IUSE=""
 
 DEPEND="media-libs/libsdl"
 
-S="${WORKDIR}/yar-${PV}"
+S=${WORKDIR}/yar-${PV}
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
-       epatch ${FILESDIR}/${PV}-math.patch
+       cd "${S}"
+       epatch "${FILESDIR}"/${PV}-math.patch
 }
 
 src_install() {
-       make DESTDIR="${D}" install || die "make install failed"
+       emake DESTDIR="${D}" install || die "emake install failed"
        dodoc AUTHORS ChangeLog README TODO
        prepgamesdirs
 }