dev-libs/libgpg-error: fix build on platforms with non-bash /bin/sh
authorFabian Groffen <grobian@gentoo.org>
Sun, 9 Jun 2019 17:52:04 +0000 (19:52 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sun, 9 Jun 2019 17:52:37 +0000 (19:52 +0200)
./autogen.sh uses advanced constructs not necessarily available in
/bin/sh, leading to empty PACKAGE_VERSION in configure after
eautoreconf.  This itself leads to a build failure due to some script
being called with too few arguments.

Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-libs/libgpg-error/libgpg-error-1.36.ebuild

index 2f5646dc9d0633080f26bc2bda86fc6504407c74..c9f3433df0033511ae4be902e5f3a48409e5b884 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit autotools libtool multilib-minimal toolchain-funcs
+inherit autotools libtool multilib-minimal toolchain-funcs prefix
 
 DESCRIPTION="Contains error handling functions used by GnuPG software"
 HOMEPAGE="http://www.gnupg.org/related_software/libgpg-error"
@@ -30,6 +30,10 @@ PATCHES=( "${FILESDIR}/${PN}-1.36-gawk5-support.patch" )
 
 src_prepare() {
        default
+       # only necessary for as long as we run eautoreconf, configure.ac
+       # uses ./autogen.sh to generate PACKAGE_VERSION, but autogen.sh is
+       # not a pure /bin/sh script, so it fails on some hosts
+       hprefixify -w 1 autogen.sh
        eautoreconf
 }