dev-cpp/libjson-rpc-cpp: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 17:06:58 +0000 (18:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 17:20:18 +0000 (18:20 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-cpp/libjson-rpc-cpp/Manifest
dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.2.0.ebuild [deleted file]

index e690a4792e1e98728c4e889e80449e7c64cc2acb..6c0de9f1f33fe6ff7beeebc88822c2df00dd507f 100644 (file)
@@ -1,2 +1 @@
-DIST libjson-rpc-cpp-1.2.0.tar.gz 180074 BLAKE2B e44f4ada4430db178949d89c3db8db18b716347d88c4f41fe558a88053ca3e2e4085fee28a87d32f710f76d57e0de9510383bc04e17adec36b754e3db2466d94 SHA512 b03507c9e9dc370d0efe94c3a69b25cbc06b99907a6c145034a283d38d7dd2188a1af89d0ce05837fde28ff96b5bd7bb0903f5865f3eae01d275929a68ea5f99
 DIST libjson-rpc-cpp-1.3.0.tar.gz 182354 BLAKE2B 512392c37e61833a98c1f682bdbb3ed0e3c72ff56f17407d49e5a0f134795daf5ff4c2702dd5222bfc8962b2c9a56c0c7856cc8fe1b923ea68c369a24d334b5c SHA512 4eb53c7b77845a0e845e42413c491dcfa1d6f72411276e8614dae6612edde8905013588465437ea39c5cc5700c2d48df07d15c83222924fc24e015fb9f7a02ea
diff --git a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.2.0.ebuild b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.2.0.ebuild
deleted file mode 100644 (file)
index 2ab9428..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="JSON-RPC (1.0 & 2.0) framework for C++"
-HOMEPAGE="https://github.com/cinemast/libjson-rpc-cpp"
-SRC_URI="https://github.com/cinemast/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +http-client +http-server redis-client redis-server +stubgen test"
-
-RDEPEND="
-       dev-libs/jsoncpp:=
-       http-client? ( net-misc/curl:= )
-       http-server? ( net-libs/libmicrohttpd:= )
-       redis-client? ( dev-libs/hiredis:= )
-       redis-server? ( dev-libs/hiredis:= )
-       stubgen? ( dev-libs/argtable:= )"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       test? ( dev-cpp/catch:0 )"
-
-RESTRICT="!test? ( test )"
-
-src_configure() {
-       local mycmakeargs=(
-               -DHTTP_CLIENT=$(usex http-client)
-               -DHTTP_SERVER=$(usex http-server)
-               -DREDIS_CLIENT=$(usex redis-client)
-               -DREDIS_SERVER=$(usex redis-server)
-               # they have no deps
-               -DTCP_SOCKET_CLIENT=ON
-               -DTCP_SOCKET_SERVER=ON
-               -DUNIX_DOMAIN_SOCKET_CLIENT=ON
-               -DUNIX_DOMAIN_SOCKET_SERVER=ON
-               # they are not installed
-               -DCOMPILE_EXAMPLES=OFF
-               -DCOMPILE_STUBGEN=$(usex stubgen)
-               -DCOMPILE_TESTS=$(usex test)
-               -DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch2"
-       )
-
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-
-       use doc && emake -C "${BUILD_DIR}" doc
-}
-
-src_test() {
-       # Tests fail randomly when run in parallel
-       local MAKEOPTS=-j1
-       cmake-utils_src_test
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       use doc && dodoc -r "${BUILD_DIR}"/doc/html
-}