app-editors/emacs-vcs: Remove sandbox hack in src_compile.
authorUlrich Müller <ulm@gentoo.org>
Mon, 18 Nov 2019 15:36:59 +0000 (16:36 +0100)
committerUlrich Müller <ulm@gentoo.org>
Mon, 18 Nov 2019 15:37:43 +0000 (16:37 +0100)
Configure with explicit option --with-dumping=pdumper to make sure
that the portable dumper is used, even for the (unlikely) case that
the upstream default would change.

Note that (as of today) --with-dumping=unexec breaks the build
process, therefore controlling this option with a USE flag wouldn't
make sense.

Closes: https://bugs.gentoo.org/700182
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild

index 832d7156dc3b293e5b527dfe44ccb42860ce14a9..baa5e8dff5e06a5f7b5377ff21d4a27f2920a736 100644 (file)
@@ -260,6 +260,7 @@ src_configure() {
                --without-compress-install \
                --without-hesiod \
                --without-pop \
+               --with-dumping=pdumper \
                --with-file-notification=$(usev inotify || usev gfile || echo no) \
                $(use_enable acl) \
                $(use_with dbus) \
@@ -281,10 +282,10 @@ src_configure() {
                ${myconf}
 }
 
-src_compile() {
-       # Disable sandbox when dumping. For the unbelievers, see bug #131505
-       emake RUN_TEMACS="SANDBOX_ON=0 LD_PRELOAD= env ./temacs"
-}
+#src_compile() {
+#      # Disable sandbox when dumping. For the unbelievers, see bug #131505
+#      emake RUN_TEMACS="SANDBOX_ON=0 LD_PRELOAD= env ./temacs"
+#}
 
 src_install () {
        emake DESTDIR="${D}" NO_BIN_LINK=t install