dev-python/pygame: [QA] Revert "Add python 3.8 support"
authorDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 14:42:18 +0000 (15:42 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 14:42:18 +0000 (15:42 +0100)
* We need to bifurcate the py2/py3 depgraph of numpy atomically,
  in order to avoid misleading and weird blocker warnings.

This reverts commit 425fd47518ffd27b6455520eeba82cabeccddad0.

Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pygame/pygame-1.9.6-r1.ebuild [deleted file]

diff --git a/dev-python/pygame/pygame-1.9.6-r1.ebuild b/dev-python/pygame/pygame-1.9.6-r1.ebuild
deleted file mode 100644 (file)
index ab8d9f1..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
-
-inherit flag-o-matic distutils-r1 virtualx
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc examples midi X"
-
-DEPEND="
-       >=media-libs/sdl-image-1.2.2[png,jpeg]
-       >=media-libs/sdl-mixer-1.2.4
-       >=media-libs/sdl-ttf-2.0.6
-       >=media-libs/smpeg-0.4.4-r1
-       midi? ( media-libs/portmidi )
-       X? ( >=media-libs/libsdl-1.2.5[X,video] )
-       !X? ( >=media-libs/libsdl-1.2.5 )
-       $(python_gen_cond_dep 'dev-python/numpy-python2:0[${PYTHON_USEDEP}]' 'python2*')
-       $(python_gen_cond_dep 'dev-python/numpy:0[${PYTHON_USEDEP}]' 'python3*')
-"
-RDEPEND="${DEPEND}"
-
-# various module import and data path issues
-RESTRICT=test
-
-python_configure() {
-       PORTMIDI_INC_PORTTIME=1 LOCALBASE="${EPREFIX}/usr" \
-               "${EPYTHON}" "${S}"/buildconfig/config.py -auto
-
-       if ! use X; then
-               sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
-       fi
-
-       # Disable automagic dependency on PortMidi.
-       if ! use midi; then
-               sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
-       fi
-}
-
-python_compile() {
-       if [[ ${EPYTHON} == python2* ]]; then
-               local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
-
-               append-flags -fno-strict-aliasing
-       fi
-
-       distutils-r1_python_compile
-}
-
-python_test() {
-       PYTHONPATH="${BUILD_DIR}/lib" virtx "${EPYTHON}" -m pygame.tests
-}
-
-python_install() {
-       distutils-r1_python_install
-
-       # Bug #497720
-       rm -fr "${D}"$(python_get_sitedir)/pygame/{docs,examples,tests}/ || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       if use doc; then
-               docinto html
-               dodoc -r docs/*
-       fi
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins -r examples/*
-       fi
-}