app-doc/devmanual: Update the live ebuild.
authorUlrich Müller <ulm@gentoo.org>
Mon, 27 Jan 2020 21:20:53 +0000 (22:20 +0100)
committerUlrich Müller <ulm@gentoo.org>
Mon, 27 Jan 2020 21:21:12 +0000 (22:21 +0100)
This accounts for several changes in the devmanual repository.

Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-doc/devmanual/devmanual-9999.ebuild
app-doc/devmanual/files/devmanual-eclasses.patch [new file with mode: 0644]
app-doc/devmanual/files/devmanual-fallback.patch

index 8ad5f06a357ecfa0d938d3fa153475226192b87a..0cd5087804b27a03f80626d77b4375c53519076a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -16,12 +16,16 @@ else
        KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
 fi
 
-LICENSE="CC-BY-SA-3.0"
+LICENSE="CC-BY-SA-4.0"
 SLOT="0"
 IUSE="+fallback"
 
-BDEPEND="dev-libs/libxslt
-       media-gfx/imagemagick[truetype,svg,png]"
+BDEPEND="dev-libs/libxml2
+       dev-libs/libxslt
+       gnome-base/librsvg
+       media-fonts/open-sans"
+
+PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
 
 src_prepare() {
        default
@@ -29,22 +33,18 @@ src_prepare() {
 }
 
 src_compile() {
-       # Imagemagick uses inkscape (if present) to delegate
-       # svg conversions.
-       # Inkscape uses g_get_user_config_dir () which in turn
-       # uses XDG_CONFIG_HOME to get the config directory for this
-       # user. See bug 463380
-       export XDG_CONFIG_HOME="${T}/inkscape_home"
-       emake
+       emake build
+       use fallback || emake documents.js
 }
 
 src_install() {
        # clean out XML/XSL before installing
        find . \( \
                -iname '*.xml' -o \
+               -iname '*.dtd' -o \
                -iname '*.xsl' -o \
                -iname '*.svg' \) -delete || die
-       rm -r README.md xsl LICENSE Makefile || die
+       rm -r bin xsl .git* LICENSE Makefile README.md || die
 
        local HTML_DOCS=( . )
        einstalldocs
diff --git a/app-doc/devmanual/files/devmanual-eclasses.patch b/app-doc/devmanual/files/devmanual-eclasses.patch
new file mode 100644 (file)
index 0000000..88b2322
--- /dev/null
@@ -0,0 +1,20 @@
+The offline version doesn't generate eclass manpages.
+Add a dummy file, otherwise internal links would be broken.
+
+--- /dev/null
++++ b/eclass-reference/text.xml
+@@ -0,0 +1,14 @@
++<?xml version="1.0"?>
++<guide self="eclass-reference/">
++<chapter>
++<title>Eclass Reference</title>
++<body>
++
++<note>
++The offline version of the devmanual does not include the documentation for the
++eclasses. If you need it, emerge <c>app-doc/eclass-manpages</c>.
++</note>
++
++</body>
++</chapter>
++</guide>
index 789451d13b2b2d0a6d3a26f2ada7faf1e4c1d58a..9e86cca39c8e4706c4ac9b588f1c18e48bbc7a64 100644 (file)
@@ -3,20 +3,18 @@ https://bugs.gentoo.org/617724
 
 --- a/devbook.xsl
 +++ b/devbook.xsl
-@@ -439,11 +439,9 @@
-           <xsl:with-param name="append">../</xsl:with-param>
-         </xsl:call-template>
+@@ -451,9 +451,7 @@
        </xsl:variable>
--      <link rel="stylesheet" href="{$relative_path_depth_recursion}devmanual.css" type="text/css" />
-+      <link rel="stylesheet" href="{$relative_path_depth_recursion}fallback.css" type="text/css" />
        <meta name="viewport" content="width=device-width, initial-scale=1.0" />
        <meta name="description" content="The Gentoo Devmanual is a technical manual which covers topics such as writing ebuilds and eclasses, and policies that developers should be abiding by." />
 -      <link href="https://assets.gentoo.org/tyrian/bootstrap.min.css" rel="stylesheet" media="screen" />
 -      <link href="https://assets.gentoo.org/tyrian/tyrian.min.css" rel="stylesheet" media="screen" />
+-      <link rel="stylesheet" href="{$relative_path_depth_recursion}devmanual.css" type="text/css" />
++      <link rel="stylesheet" href="{$relative_path_depth_recursion}fallback.css" type="text/css" />
        <link rel="icon" href="https://www.gentoo.org/favicon.ico" type="image/x-icon" />
      </head>
      <body>
-@@ -476,9 +474,6 @@
+@@ -486,9 +484,6 @@
                </div>
                <div class="logo">
                  <a href="/" title="Back to the homepage" class="site-logo">
@@ -26,15 +24,72 @@ https://bugs.gentoo.org/617724
                  </a>
                  <span class="site-label">Development Guide</span>
                </div>
-@@ -566,8 +561,6 @@
+@@ -530,45 +525,7 @@
+             </div>
+           </div>
+         </nav>
+-        <nav class="navbar navbar-grey navbar-stick" id="devmanual-actions" role="navigation">
+-          <div class="container">
+-            <div class="row">
+-              <div class="navbar-header">
+-                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#gw-toolbar">
+-                  <span class="sr-only">Toggle navigation</span>
+-                  <span class="icon-bar"></span>
+-                  <span class="icon-bar"></span>
+-                  <span class="icon-bar"></span>
+-                </button>
+-              </div>
+-              <div class="collapse navbar-collapse" id="gw-toolbar">
+-              <div class="input-group">
+-                <input type="search" name="search" placeholder="Search" title="Search Gentoo Developer Manual [f]" accesskey="f" id="searchInput" class="form-control" onclick="fetchDocuments()"/>
+-                <div class="input-group-btn">
+-                  <input type="submit" name="fulltext" value="Search" title="Search the pages for this text" id="mw-searchButton" class="searchButton btn btn-default" onclick="search()"/>
+-                </div>
+-              </div>
+-            </div>
+-          </div>
+-        </div>
+-      </nav>
+       </header>
+-      <div id="searchResults" class="modal fade" role="dialog">
+-        <div class="modal-dialog">
+-          <div class="modal-content">
+-            <div class="modal-header">
+-              <button type="button" class="close" data-dismiss="modal">x</button>
+-              <h4 class="modal-title">Search Results</h4>
+-            </div>
+-            <div class="modal-body">
+-              <p>No results found.</p>
+-            </div>
+-            <div class="modal-footer">
+-              <button type="button" class="btn btn-default" data-dismiss="modal">Close</button>
+-            </div>
+-          </div>
+-        </div>
+-      </div>
+       <div class="container">
+         <div class="row">
+           <div class="col-md010">
+@@ -613,19 +570,7 @@
            </div>
          </div>
        </footer>
 -      <script src="https://assets.gentoo.org/tyrian/jquery.min.js"></script>
 -      <script src="https://assets.gentoo.org/tyrian/bootstrap.min.js"></script>
+-      <script src="https://assets.gentoo.org/lunr/lunr.min.js"></script>
+-      <xsl:variable name="relative_path_depth" select="string-length(/guide/@self)-string-length(translate(/guide/@self, '/' , ''))"/>
+-      <xsl:variable name="relative_path_depth_recursion">
+-          <xsl:call-template name="str:repeatString">
+-            <xsl:with-param name="count" select="$relative_path_depth"/>
+-            <xsl:with-param name="append">../</xsl:with-param>
+-          </xsl:call-template>
+-      </xsl:variable>
+-      <script><xsl:text>var documentsSrc = "</xsl:text><xsl:value-of select="$relative_path_depth_recursion"/><xsl:text>documents.js"</xsl:text></script>
+-      <script src="{$relative_path_depth_recursion}search.js"></script>
      </body>
      </html>
    </xsl:template>
 --- /dev/null
 +++ b/fallback.css
 @@ -0,0 +1,20 @@