dev-qt/qtpositioning: Backport geoclue2 plugin to replace SLOT 0
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Dec 2018 00:52:09 +0000 (01:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Dec 2018 22:09:47 +0000 (23:09 +0100)
Development of the plugin seems to be contained in the geoclue2 subdirectory
only, which makes packing it into a tarball relatively simple.

Upstream commits (in 5.12.0):
f0472774b36c862f5fb6822f2d4d63a967d1eaec
4ef6b50278c041336f794cef20dd7e30fe8fbec0

Bug: https://bugs.gentoo.org/563588
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtpositioning/Manifest
dev-qt/qtpositioning/qtpositioning-5.11.3.ebuild

index f9b5f2855ab4fe4930d0ac954877b45b7cd269b9..35c414c0bd55013b619c83983912db90125840d6 100644 (file)
@@ -1,3 +1,4 @@
+DIST qtlocation-5.11.3-geoclue2.tar.xz 7556 BLAKE2B 2648b2e8aa8dadad467c7a3ea352014ca832021b12af0e11c563e328d4b6321df8d2784744437e9348feda1ed443c0e56882491b1811e734d43b036e6b5e7c16 SHA512 226ae607b4a0d55ed3207a19932ed685a44e688c6b27407d576fac73e29be478ac3d3b06d93a3bd594ee6443648a9c86b9746366e6765451080af4c1b2ee4264
 DIST qtlocation-everywhere-src-5.11.1.tar.xz 5593144 BLAKE2B cd9fe409ecc3f3dde665f4bb77f93d515b88bce382655adcbfc9f60b7f7446abe800a91d612fa4b379efa9a783a4158ed34ff1ce11b3ea929e087062d0fa6f1a SHA512 8b89aae5bb7caa0999c20c86da1a356e5ba21e1e12ac892a695d180f21527846aa45f926828934b83147b851145477028ff1212802c1c21f8f6bb4e616b8b1fd
 DIST qtlocation-everywhere-src-5.11.2.tar.xz 5584420 BLAKE2B e7b0cd716edab33d19f1b9ef519a35ea8094ccc85ce015eb7f3e26c61f62bcc7ff9419dd79da5d8ebec9f3b0630cea7c125f237ed39b7ed1917a45408cf7dc51 SHA512 84a52aedac59f1bc4372538dc0810c742f87f04b2ee599e7ed3f8f0cfe0e13d652e80d3cf7de95395bbe1285a60cc15791760e17f0975cf8399527cdadbd7c1b
 DIST qtlocation-everywhere-src-5.11.3.tar.xz 5589440 BLAKE2B 544d90151fcbaf8a75d374e4acec9bbd78b63c2dee0258f1e08e18ffb94a86c91f63dd8c9215af96e3648d50a40fe6b66c105abec0ab6dd4473903a06f2d0253 SHA512 880cd6983bc0b4c5ac5a1edb2b3ffbe89f133bd819e4bea4fb8e91ba8d847ab80572743e3994145ee6697cb2fc24c393ac3c4ead847a022d848799eaa4982716
index 4e2637ef4795c1e43e528459a445b8adf804364d..209467ba52058140e8718dedbf139acecc1e1091 100644 (file)
@@ -6,6 +6,7 @@ QT5_MODULE="qtlocation"
 inherit qt5-build
 
 DESCRIPTION="Physical position determination library for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${QT5_MODULE}-${PV}-geoclue2.tar.xz"
 
 if [[ ${QT5_BUILD_TYPE} == release ]]; then
        KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
@@ -20,7 +21,7 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}"
 PDEPEND="
-       geoclue? ( app-misc/geoclue:0 )
+       geoclue? ( app-misc/geoclue:2.0 )
 "
 
 QT5_TARGET_SUBDIRS=(
@@ -32,9 +33,14 @@ QT5_TARGET_SUBDIRS=(
 )
 
 pkg_setup() {
-       use geoclue && QT5_TARGET_SUBDIRS+=(src/plugins/position/geoclue)
+       use geoclue && QT5_TARGET_SUBDIRS+=( src/plugins/position/geoclue2 )
        use qml && QT5_TARGET_SUBDIRS+=(
                src/positioningquick
                src/imports/positioning
        )
 }
+
+src_prepare() {
+       sed -i -e "/qtHaveModule/s/geoclue/geoclue2/" src/plugins/position/position.pro || die
+       qt5-build_src_prepare
+}