Fix build failure due to gettext mismatch (#567976)
authorEray Aslan <eras@gentoo.org>
Thu, 24 Dec 2015 07:41:25 +0000 (09:41 +0200)
committerEray Aslan <eras@gentoo.org>
Thu, 24 Dec 2015 07:41:25 +0000 (09:41 +0200)
Package-Manager: portage-2.2.26

net-mail/mailutils/mailutils-2.99.99.ebuild

index aac4a572887f4e85aed831a093d1d3644ca4386e..28d02559242397d9bf5bc11793a70863ac2b2341 100644 (file)
@@ -60,11 +60,13 @@ src_prepare() {
        echo "#!/bin/sh" > build-aux/py-compile
        epatch "${FILESDIR}/${PN}-2.99.98-readline-6.3.patch" #503954
        epatch "${FILESDIR}/${PN}-tcp_wrappers.patch"
+       # bug 567976
+       sed -i -e /AM_GNU_GETTEXT_VERSION/s/0.18/0.19/ configure.ac || die
        if use mysql; then
                sed -i -e /^INCLUDES/"s:$:$(mysql_config --include):" \
                        sql/Makefile.am || die
-                       eautoreconf
        fi
+       eautoreconf
 }
 
 src_configure() {