dev-java/ant-eclipse-ecj: added version 3.7
authorMiroslav Šulc <fordfrog@gentoo.org>
Wed, 19 Oct 2011 19:50:27 +0000 (19:50 +0000)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 19 Oct 2011 19:50:27 +0000 (19:50 +0000)
Package-Manager: portage-2.1.10.29/cvs/Linux x86_64

dev-java/ant-eclipse-ecj/ChangeLog
dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.1.ebuild [new file with mode: 0644]
dev-java/ant-eclipse-ecj/files/ecj-3.7 [new file with mode: 0644]

index 99b28aead3c43773cafa3fbc0a9a02ef3dfb539f..2e7dbc3b15a3bcc08f0f83cbee45c8a5cea4a64e 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-java/ant-eclipse-ecj
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.26 2011/10/19 18:47:33 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.27 2011/10/19 19:50:27 fordfrog Exp $
+
+*ant-eclipse-ecj-3.7.1 (19 Oct 2011)
+
+  19 Oct 2011; Miroslav Šulc <fordfrog@gentoo.org> +files/ecj-3.7,
+  +ant-eclipse-ecj-3.7.1.ebuild:
+  Added version 3.7 (bug #380165, thanks William L. Thomson Jr.
+  <wlt@obsidian-studios.com> for the ebuild)
 
   19 Oct 2011; Miroslav Šulc <fordfrog@gentoo.org>
   -ant-eclipse-ecj-3.6.ebuild:
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.1.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.1.ebuild
new file mode 100644 (file)
index 0000000..cb51dd1
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.1.ebuild,v 1.1 2011/10/19 19:50:27 fordfrog Exp $
+
+EAPI=4
+
+inherit java-pkg-2
+
+DMF="R-${PV}-201109091335"
+S="${WORKDIR}"
+
+DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF/.0}/ecjsrc-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+SLOT="3.7"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4
+       ~dev-java/eclipse-ecj-${PV}
+       >=dev-java/ant-core-1.7"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       >=virtual/jdk-1.4"
+
+src_unpack() {
+       unpack ${A}
+       mkdir -p src/org/eclipse/jdt/{core,internal}
+       cp org/eclipse/jdt/core/JDTCompilerAdapter.java \
+               src/org/eclipse/jdt/core || die
+       cp -r org/eclipse/jdt/internal/antadapter \
+               src/org/eclipse/jdt/internal || die
+       rm -fr about* org
+}
+
+src_compile() {
+       cd src
+       java-pkg_filter-compiler jikes
+       ejavac -classpath "$(java-pkg_getjars ant-core,eclipse-ecj-${SLOT})" \
+               $(find org/ -name '*.java') || die "ejavac failed!"
+       find org/ -name '*.class' -o -name '*.properties' | \
+                       xargs jar cf "${S}/${PN}.jar" || die "jar failed!"
+}
+
+src_install() {
+       java-pkg_dojar ${PN}.jar
+       insinto /usr/share/java-config-2/compiler
+       doins "${FILESDIR}/ecj-${SLOT}"
+}
diff --git a/dev-java/ant-eclipse-ecj/files/ecj-3.7 b/dev-java/ant-eclipse-ecj/files/ecj-3.7
new file mode 100644 (file)
index 0000000..49b17dc
--- /dev/null
@@ -0,0 +1,7 @@
+JAVAC="/usr/bin/ecj-3.7"
+PACKAGE="=dev-java/ant-eclipse-ecj-3.7*"
+SUPPORTED_TARGET="1.1 1.2 1.3 1.4 1.5 1.6 1.7"
+SUPPORTED_SOURCE="1.3 1.4 1.5 1.6 1.7"
+ANT_BUILD_COMPILER="org.eclipse.jdt.core.JDTCompilerAdapter"
+ANT_BUILD_COMPILER_DEPS="eclipse-ecj-3.7,ant-eclipse-ecj-3.7"
+GENERATION="2"